This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 12, 2018 at 2:27 pm #2727944

paulV-7

The base url gets switched out in our gravity form, on dutch, the base language it works fine however not on the translated pages.

URL: hidden link
Query String: trackingnr={Track & Trace:1}

The url gets build by gravity forms, with a query string. Now i've tried translating and not translating the url, same result

Check these pages below:
hidden link
- hidden link

hidden link
- hidden link

hidden link
- hidden link

September 14, 2018 at 5:02 pm #2736224

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @paulv-7, welcome to the WPML support Forum!

Sorry for the delay. We are with a large volume of support requests at the moment. this is not usual in our forum.

Could you please elaborate a little more on this issue, so I can better understand? E.g. The link of the page, how to reproduce the issue, steps you've tried, etc. Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

--- This is our guide on how to use Gravity Forms with WPML: https://wpml.org/documentation/related-projects/gravity-forms-multilingual/

I also checked the settings of your server through debug log and saw that some items need attention:

Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 2000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Please let me know if it worked for you.

All the best,
Diego

September 19, 2018 at 6:42 am #2747428

paulV-7

First of all, the installation is fine, not sure why the debug show lower values? But the memory limit is set to 256mb and although max input vars is lower. Don't think the problem is here but, good to check.

To elaborate on the problem, we have three languages, i've translated the form for each language. The form on submit has a redirect link to an external site with track & trace, the t&t code is added in as parameter, on the base language you get redirect correctly. However on Spanish & English the base of the url gets switch out with our URL. Just try entering something in the form, the links are in the previous post. Hope this was more clear.

September 19, 2018 at 6:41 pm #2749789

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks for the feedback. I checked the URL's and it seems that the correct URL is hidden link

On the other URL's, I get a 404 error (and also a SSL error):
- hidden link
- hidden link

It seems that the tracktrace.php is not generated by WordPress, but it's a custom PHP script. As you are using different domains per language, The file is not found when you use the secondary domains, because it's not part of the WP structure.

It's possible to use the absolute URL on the gravity forms? Or it's build automatically? If posible, you can point all forms to the "hidden link" URL.

Please let me know if it worked for you.

Kind Regards,
Diego

September 20, 2018 at 8:01 am #2751331

paulV-7

Hi Diego,

Yes the tracktrace.php is external, it's a track and track provider. But the url to it is generated by gravity forms.
See the image, sorry it is dutch. It's under settings > confirmations > redirects in english I think and there it is a redirect.

So I can't point to an absolute URL as the tracktrace.php needs the input in the url
WPML seems to switch out the base of that url.

September 20, 2018 at 6:35 pm #2753061

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

There is a absolute URL set on the "Doorverwijs-URL". Is this URL being modified in translations?

It would be nice to test this issue on a clean install. If this is a new compatibility issue, I can escalate it to our compatibility team.

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the gravity forms to this test install and setup it the same way as in your website (using the same options). Please note that we only need the plugin, the related functionality and some dummy content to reproduce the issue. You don't need to setup a entire website or clone your existing site.

Regards,
Diego

September 27, 2018 at 7:02 am #2769473

paulV-7

Hi Diego,

Sorry for the delay, I installed Gravity Forms in the your sandbox environment, yet i'm not able te reproduce the issue. However it might have something to do with the domains we set for the site. As where using globalistics.es globalistics.nl and en.globalistics.nl. I've setup one form to test

September 27, 2018 at 5:12 pm #2771344

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Perhaps the issue is related to different domains per language. In this case, would it be possible to create a test copy of the website on your server (staging version)? In this way, we can do some tests without modifying the original site.

You can use a plugin like Duplicator or All-in-one WP Migration to duplicate the website. After that, please make sure to setup the different domains per language on the test website as well.

Kind regards,
Diego

The topic ‘[Closed] Gravity forms translate redirect link.’ is closed to new replies.