This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by ooluja 6 years, 9 months ago.

Assigned support staff: sarah.n.

Author Posts
December 27, 2012 at 10:12 am #93257

ooluja

http://wpml.org/forums/topic/the-gravity-forms-translation-always-need-update/

hi, i have same problem as posted in link above.
Topic is closed, solution found but not posted.

Some help on this problem would be much appreciated.

December 27, 2012 at 10:54 am #93267

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello ooluja,

Can you please provide the WordPress version as well as the plugin versions of WPML and its active add ons?

Please include the Gravity Forms version as well as the Gravity Forms multilingual.

Can you also please make sure that "Auto-register strings only when logged in as an administrator" is checked under "WPML -> String Translation"?

Thank you!

December 27, 2012 at 11:24 am #93271

ooluja

Gravity Forms / 1.6.5.1
Gravity Forms multilingual / 0.9.3

WPML CMS Nav / 1.2.7
WPML Multilingual CMS / 2.6.2
WPML String Translation / 1.5.2
WPML Translation Management /1.4.2

Yes, "Auto-register strings only when logged in as an administrator" is checked...

December 27, 2012 at 2:32 pm #93292

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello ooluja,

Can you please update your plugins to their latest versions first?

You'll need:
Gravity Forms / 1.6.6.9
Gravity Forms multilingual / 0.9.3
WPML Multilingual CMS / 2.6.3
WPML String Translation / 1.5.3
WPML Translation Management /1.4.3

Then if the problem persists after the update, I'd like to replicate the problem you have so could you please describe the steps I need to take in order to do so? If you think it may help, please take sceenshots of what you see (i.e. the problem at hand) so I can be in a better position to help.

Thank you.

December 31, 2012 at 9:59 am #93666

ooluja

Hello Sarah,
have uploaded all plugins to latest version, but problem persists..
I will now explain where I have problem and give you screenshots..
After sending form in addon language (English), got message in String translation - Translation needs update..
Have WP 3.5, 3 languages (main Croatian, addon English and German).

1.hidden link
form in english translation, modal window (same problem if form is on page)
2. hidden link
confirmation message translated in english
3. hidden link
same form after refreshing page (F5) in Firefox (tryed in other browser - Chrome, IE, Safari, Opera - same result)
4. hidden link
hidden link
String Traslation - Translation needs update

Amazing is that not all fields in form need update - 17_field-10-label (Email), and 17_title (Servis/Izleti) got Translation complete... Have tryed to make new form, translate again same results.. Tryed to duplicate form, translate same results.. In WPML, Support, clicked on troubleshooting page, and then Set Language information same results.. Then Remove ghost entries from translation table - same result... Conclusion - after sending form my translations are not enabled any more... Waiting for answer..

January 1, 2013 at 6:19 am #93732

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello ooluja,

I will try to replicate the problem and get back to you once I know more.

January 1, 2013 at 12:32 pm #93752

ooluja

Hello Sarah, Happy New Year to you and all stuff from wmpl 😉

Have made clean WP install - 3.5, added wpml and gravity form plugin (like above in question), add one form and translated the form...

you can see it on: hidden link...
So please can you use english language - hidden link and enter fields in form, after submit you will get message, and then refresh page and you will see that translation is gone (String Translation – Translation needs update)... i can give to you ftp/user login if you want..

January 1, 2013 at 1:00 pm #93753

ooluja

OMG, just LOL! 😉

I have found solution: if you are WPML translator (like me admin), and if you test form, after submiting you will get translations need update.. After logout, and then trying the form, all is WORKING!!! I can't belive 😉
So in future, will not test form when I logged in like admin..

January 1, 2013 at 1:41 pm #93757

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Ooluja,

I tested the form you created. After refreshing the page I still see the form in English.

Is the issue resolved?

January 1, 2013 at 1:52 pm #93760

ooluja

Yes issue is resolved, no more testing forms logged in as admin 😉 Tnx