We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: when translating Gravity Forms, translation is stuck at 99% and doesn't complete

Solution: the form was large so the value max_chars wasn't enough to save it. Increasing the value solved the issue.

This topic contains 4 replies, has 2 voices.

Last updated by josv-12 1 month, 1 week ago.

Assigned support staff: Laura.

Author Posts
October 1, 2019 at 1:25 pm

josv-12

I am trying to:
Translate gravity forms into 4 other languages. We see now that all translation jobs remain at 99%. It seems like newly added form elements are impossible to save and update (it does work using string translation, when looking at chrome inspector, saving response is 200). Turkish translation does not work at all. If we look at string translations, all turkish translations are missing.

Link to a page where the issue can be seen:
hidden link

I expected to see:
Turkish translation.

Instead, I got: Fallback dutch translation

We have also tried to rebuild caches etc, all steps as described in attached image.

Since the site is not in production yet, feel free to check. I have a DB dump.

October 1, 2019 at 2:19 pm
October 1, 2019 at 2:45 pm #4673055

josv-12

if I translate these last fields and mark them as translated, they become untranslated again the next time I open.

October 2, 2019 at 10:51 am #4679343

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

could you please check if there are errors in the browser console or in the WordPress debug log?

To activate the WordPress debug log, edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

October 6, 2019 at 2:04 pm #4702591

josv-12

Hi,

it turned out I reached the max_chars of 1500 (it's a large form). Increasing this to 3000 solved the issue. Thanks for the support

October 6, 2019 at 2:04 pm #4702593

josv-12

My issue is resolved now. Thank you!