Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by Bobby 11 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
December 4, 2019 at 7:22 pm #5072025

bothienB

I am trying to: Translate a Gravity View 'view'

Link to a page where the issue can be seen: n/a

I expected to see: Translated custom fields (standard fields translation are handled by Gravity Form already)

Instead, I got: Non translated custom fields. I can edit them but when I'm saving the view, all the changes are lost.

Gravity View settings as per the screenshots

December 4, 2019 at 7:38 pm #5072209

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I have enabled the private field reply, feel free to reply once ready.

December 4, 2019 at 8:03 pm #5072365

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I have enabled the private field reply, feel free to reply once ready.

December 5, 2019 at 2:50 pm #5077609

bothienB

Bobby,
I gave up trying to solve the problem bc Gravity View never answered my questions (I went to you because of that) and there's no reason you/me lose time over this.

I made a workaround using your [wpml-string] shortcode within the view et voila, now I have what I want (tbh, even more efficient since I collect all (deduplicated) strings in the same package and that's more efficient than working on a "field by field" basis).

Sure it's not 100% satisfying for me but I can't afford more (unpaid) delays; I've spent more than 10 days on this and other (WPML +) plugins "problems", had to check a multitude of times that there was no other side effects and frankly, I'm exhausted. "Done is better than perfect".

So, I'm not sure what your further investigations will be, I'll be happy to know anyway, so please keep me posted; but if you have to close the ticket, no problem at all.

Thanks for your help,
BR
Antoine (the developer, in the name of bothienB)

December 6, 2019 at 8:10 pm #5085841

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi Antoine,

As I am not familiar with this issue my tests would include trying to reproduce it in order to determine if this is being caused 1. by Gravity forms 2. by WPML 3. or due to a compatibility issue.

I understand that the issue has been time-consuming and If the workaround you are using has resolved the issue and you are content with it, we can close the ticket but if you wish we can take a closer look at it I can create a duplicator package for further testing locally.

The topic ‘[Closed] Gravity View translated view revert to original language after saving’ is closed to new replies.