This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by damjanJ-2 3 weeks, 6 days ago.

Assigned support staff: Noman.

Author Posts
September 24, 2019 at 7:59 pm

damjanJ-2

I am trying to: Make a transparent background for language switcher

Link to a page where the issue can be seen:hidden link

I expected to see: transparent background on hover on all items

Instead, I got: grey background on current language item when I hover over other options and I cannot locate in the browser inspector

September 25, 2019 at 4:54 am #4635647

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. You can fix this issue by adding below CSS in WPML >> Languages >> Additional CSS section:

.wpml-ls-legacy-dropdown a:hover, 
.wpml-ls-legacy-dropdown a:focus, 
.wpml-ls-legacy-dropdown .wpml-ls-current-language:hover>a {
    color: #fff !important;
    background: transparent !important;
}

And it will look as in the attached screenshot.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

September 25, 2019 at 6:24 am #4635897

damjanJ-2

Great. That fixed my issue. Thanks!