Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Yvette 1 year ago.

Assigned support staff: Yvette.

Author Posts
January 20, 2019 at 4:05 pm #3109652

Olivier

I am trying to: go to the group activity

Instead, I got: server site activity

January 21, 2019 at 7:07 am #3110755

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

Please provide more details on the problem that you describe. Perhaps if you upload a screenshot that illustrates the issue, this can help me understand what WPML issue might be at hand.

Please tell me the steps to execute to see the problem on your site.
Does this problem happen only in one language?
When you temporarily deactivate all non-WPML plugins - does the problem go away?

Thanks

January 21, 2019 at 7:58 am #3110881

Olivier

Hello Yvette
Sorry my previous ticket was an automatic converted from your chat and does not include all information..

My website hidden link is a buddypress / Woffice / Wpml website.
When you go in buddypress group and select activity now you are redirecxted to the site wide activity and not on the group activity !

Yes, if i deactivate WPML and buddypress multilingual plugins this is working fine, in the group activity you see only the activity of the related group. I test with deactivate all plugins except buddypress and the problem is the same.

It was working fine for years but i discover this bug after doing the last recent updates (WP, plugin & theme) .... (do not know exactly which one is responsible of this situation)

To see that in our site you need to be login (i can create a login for you if need)

Olivier

January 21, 2019 at 1:59 pm #3112736

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Yes, please provide admin access. I am opening the private area for system access details.
Please also provide detailed steps I need to execute to replicate the error you describe.

Clarification
You wrote ":.When you go in buddypress group and select activity now you are redirecxted to the site wide activity and not on the group activity !"

Question: is this happening in both the primary and secondary languages of your site?

Thanks

January 21, 2019 at 4:04 pm #3113142

Olivier

sorry some problem of availability of your server 🙂

Olivier

January 22, 2019 at 11:53 am #3116071

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

This seems to be an issue with your theme. When I reduce the number of active plugins to a minimum (only WPML and Buddypress) and switch your theme to the Buddypress default, then the link will show only the group activity stream . (see image)

With the same plugins activated, the same URL provides a different UI with the "Activity" button. This is not able to resolve to a group only view and it would be here where the incompatibility lies.

Normally, as this is not certified as a compatible theme, our next step is to replicate the issue on a sandbox site and send the site to our compatibility team for further analysis and possible resolution/workaround.
https://wpml.org/documentation/theme-compatibility/

I should warn you that the process is not always able to provide you a quick solution as it relies on the collaboration of the theme/plugin author and ususally involves additional code changes on their part. The time to resolution (if any) therefore is dependent on the availability and willingness of the author to work with our team and may be precluded due to complexity or non-interest to modify the required code.

Before I start the compatibility process, I need your confirmation that you understand the process and are still willing to move forward. Another approach is for you to seek support from the theme author directly and have them contact our compatibility team via this link:
https://wpml.org/documentation/theme-compatibility/go-global-program/

January 22, 2019 at 3:31 pm #3117242

Olivier

Hi Yvette
Thank you very much for your support
It seems clearly that this is a theme issue and really sorry that i do not verify this myself ...

Leave this ticket open i will see with the theme editor and if no solution is found i will be back to you

Best regards
Olivier

January 22, 2019 at 3:36 pm #3117253

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

No problems, this ticket will remain open in your inbox until you decide to close it or reply with more updates.

January 22, 2019 at 4:50 pm #3117460

Olivier

Hi Yvette
the problem is solved and seems due to the implementation of Woffice of some new features of buddypress group.
I discover it by chance...
in fact the first time an administrator access to one of the groups with Woffice theme this is asking it to define what he want for this group default home page...
(but only on the public web site, not in the admin panel 🙂
after the administrator define it all is working fine.
I do it on our production site and this is ok
in fact this should be defined in :
Appearance - Customize - New Buddypress - Home for groups (my is in french not sure of exact name)
And then just deactivate the "Custom home page for groups".

This ticket is close for my point of view and thank you to helped me to go in the right direction...

Best regards
Olivier

January 23, 2019 at 7:17 am #3119119

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Perfect! Thanks for sharing the final solution to the issue.