This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Gutenberg does not show options in the profile language

Solution: updated the WPML plugins to it's beta versions.

Tagged: 

This topic contains 12 replies, has 3 voices.

Last updated by Michele 2 months ago.

Assigned support staff: Riffaz.

Author Posts
August 6, 2019 at 5:18 am #4344213

Michele

website primary language is Japanese, it has English as secondary language

I am trying to:
edit or add a page

I expected to see:
all editor's option in English, since that is the language I selected for my user

Instead, I got:
some of the options and info tooltips are in Japanese

August 6, 2019 at 6:42 am #4344419

Michele

the issue is present also when I try to create an English translation for a page or post

August 6, 2019 at 7:35 am #4344699

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

We need to check this in a fresh installation.

please,
1. go to hidden link
2. configure the WPML as you have it on your site. at the last step just click next (site key)
3. create only one page with element you are using.
4. recreate the issue.
5. let us know how to check this and how to recreate this issue.
6. explain the step 8 with screenshots and URLs for better understanding.

Regards,

August 6, 2019 at 9:08 am #4345613

Michele

I did start by setting up Japanese as primary language and english as secondary
but after that I cannot seem to be able to set English (United States) as my user (demo) language, after I save the setting, it goes back to site default (サイトデフォルト)

August 6, 2019 at 12:54 pm #4347637

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

1. go to hidden link
2. login using username: user1 and password: Test@123

then do the rest.

Let me know how it goes.

Regards,

August 7, 2019 at 9:37 am #4353247

Michele

hi Riffaz,

thank you for the new instructions.

Meanwhile, I come to think that for the time and effort I would need to recreated the website on your server, I'd better try and recreate the website on one of my servers... if the problem is there I can give you access before adding any content... if the problem is not there or if you can fix it, I can then move my content to it and be happy.

My issue is not resolved, but I won't be able to get back to this for quite some time I am afraid, since rebuilding the website will be time consuming.

August 7, 2019 at 11:35 am #4354389

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

That sounds good but you do not have to recreate the whole site.
As per the sandbox site I gave you, you just have to configure the WPML and Gutenberg only in the sandbox just like you have it on your just.
So we can start troubleshooting in the fresh, bug free environment.

Anyhow, take your time and get back to us when you are ready.

Regards,

August 19, 2019 at 10:49 am #4415375

Michele

@Riffaz
while setting up a sandbox for a different issue, I managed to reproduced the one I reported here... I hope this will be enough for you to investigate and find what I am doing wrong 🙂

August 20, 2019 at 1:08 pm #4423863

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Thank you @bruno-k

@himmkx
We are checking this internally.
I will update again once we have something regarding this.

Regards,

August 20, 2019 at 11:53 pm #4426811

Michele

thank you Riffaz, I have two websites with this issue, I hope it can be fixed.

August 22, 2019 at 12:40 pm #4439453

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I fixed the issue in the sand box: hidden link

How?
I updated the WPML plugins to it's beta versions.
That's what our developers also suggest for now.

You can download the latest beta here: hidden link

Let me know if you need anything else regarding this.

Regards,

August 23, 2019 at 12:24 am #4443233

Michele

it fixed my issue in both the website were I was experiencing it.

in one, some of the Woocommerce settings were in mixed languages that is solved as well.
Some of the Toolset options were also in the wrong language, I can't confirm 100% that is solved because that looked quite random, but at first glance it looks like so.

My issue is resolved now. Thank you!

October 8, 2019 at 8:32 am #4713167

Michele

well... the bets plugin ended up breaking up the websites since it was incompatible with string translations and translations management.

none of the recent updates has solved the issue.

I keep having to use the admin part of the website in a language I cannot read... also, since a month or so, the list of pages shows both English and Japanese on the same table, no matter which language I choose