This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Andreas W. 4 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 5, 2019 at 11:12 am #3959759

mattiZ

I am trying to: Edit a post with the Gutenberg editor

Link to a page where the issue can be seen: Can't - local dev

I expected to see: Gutenberg editor interface in English

Instead, I got: Gutenberg editor interface in Arabic. The dashboard is correctly in English. When I disable WPML the issue is fixed

June 5, 2019 at 11:17 pm #3964457

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

As far I understand the default language for WPML is WordPress is English?

Could you please go to Edit My Profile -> WPML language settings and set the option:

"Set admin language as editing language"

I hope this will solve the issue.

Kind regards
Andreas

June 6, 2019 at 6:12 am #3965969

mattiZ

Hi,
The default lang is Arabic. The user profile language is set to English. As you can see in the screenshot the Dashboard is correctly in English - whereas the gutenberg editor is in the wrong lang. I had already tried your suggestion about "Set admin language as editing language". Didn't help. While editing English posts the gutenberg interface was still in Arabic

June 6, 2019 at 12:44 pm #3969291

mattiZ

I'm still investigating. I've noticed that the translations are coming from the String Translations plugin listed in the "default-wp-format-library" text domain. I actually don't use String Translations, so I tried to disable it with the "Don't use String Translation to translate themes and plugins" setting, but it remains active and continues to cause the unwanted interface translations.

June 6, 2019 at 5:28 pm #3971199

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

The topic ‘[Closed] Gutenberg editor language not in Admin language’ is closed to new replies.