This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Acf fields not visible in the post editor screen on particular language

Solution: ACF field groups are set to translate mode however the translation is not done to the appropriate language, Setting the Field Group post type to "Not translate" from WPML > Settings > Post type translation resolves the issue

Relevant Documentation: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-field-groups

This topic contains 14 replies, has 2 voices.

Last updated by jessicaT-2 4 weeks, 1 day ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 29, 2019 at 8:45 pm

jessicaT-2

When Gutenberg was enabled new and existing WPML translated pages lost the ability to display Custom page templates that were created using Advanced Custom Fields.

Example: staging7.legacytree.com/es/projects

We've created staging7.legacytree.com to test without disturbing our live website.

August 30, 2019 at 9:59 am #4486165

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

It seems you are using an older version of WPML 4.2.0, Kindly update the WPML and its add on plugins to the latest version.

If you don't see the update notice in the plugins list, try updating the plugins manually

* Steps to manual update
-- Backup your site and database
-- Deactivate the WPML plugin from WP dashboard plugins section, This won't delete any data
-- Download a fresh copy of WPML plugin from you WPML account dashboard https://wpml.org/account/downloads/
-- Upload a fresh copy of the newer version of WPML multilingual CMS plugin to your site
-- Activate the plugin and register if required
-- Update the rest of the WPML plugin from plugins > Add New > Commercial Tab

Make sure to install Advanced custom fields Multilingual plugin to translate ACF fields using WPML, Check the detailed documentation on how to translated ACF fields using WPML
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Let me know if you need further assistance.

Kind regards
Raja

September 4, 2019 at 5:47 pm #4513285

jessicaT-2

Hi Raja,
I've followed your instructions to download the latest version of WPML and the ACF Multinlingual plugin; however the fields on the translated pages are still not showing up. The custom fields are being listed, but the editor part is still missing.

September 5, 2019 at 7:06 am #4515981

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sure, let me check this on your site.

It seems your site is htaccess protected, Please share the access credentials to access your site. I have enabled private fields again to securely share the details.

September 5, 2019 at 11:08 am
September 5, 2019 at 11:16 am #4518723

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The access you have share is for the dashboard. Your site seems to be restricted with dual access protection from htaccess, Can you please pass on the access key to view your site. Please refer to the screenshot, I need the details for the popup login.

September 5, 2019 at 11:20 am
September 6, 2019 at 6:58 am #4523523

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sorry, that didn't help as well. Please check with your developers if you are creating new access edit your previous reply to add the updated details. let me know once it is done.

September 6, 2019 at 1:30 pm #4525541

jessicaT-2

Hello - my name is Rick Stewart and I am a developer.

This is the step-by-step instructions I just used to access the staging server using a browser ( FF ) that has never logged into this website. I use Chrome for day to day work.

Okay -

1 - I used this link to access the staging server, staging7.legacytree.com/projects
2 - At the popup say Authentication Required is used this the second set of credentials sent to you.

PLEASE NOTE: The SiteGround server rejected my first several attempts to log in using these credentials. On my 3rd try I cut out the password and pasted in the password a second time, and then it let me in.

3 - I logged into the wp-admin area using the login originally sent to you

4 - So now opening up the page hidden link in the backend editor I see that the page is using a custom page template called "New Project Template". Scrolling down the page I can see extra wysiwyg data entry areas created by ACF, Advanced Custom Fields. They are, from top to bottom:

Top Header
Top Content
Services Section
Sub Heading 1
Our Genealogy Packages
Services Section 2
Sub Heading 2
Sample Research Reports Heading
Sample Research Reports
Sub Heading 3
Get Started Today
5 - So far so good. Now if I open the Portuguese version of this page at hidden link and then open the page in the backend editor I see the custom page template is still "New Project Template", however all of the ACF wysiwyg editor fields are missing.

If we disable WPML the come back.

September 9, 2019 at 8:05 am #4534347

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the steps, I am able to access the site on the third attempt.

It seems the translation preference for Acf fields are set to "Don't Translate" which is why you are unable to see the fields in the translation editor.

Please set the ACF fields translation preference to "Translate" in order to make the fields translatable. refer to the detailed documentation on how to set the fields to translate https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-simple-fields

Alternatively, the change of translation preference can be applied to all available custom fields from WPML > Settings > Custom fields translation, Set all the required custom fields to "Translate" hit apply.

I hope this helps you resolve your issue.

Kind Regards
Raja

September 11, 2019 at 4:07 pm #4555173

jessicaT-2

As you suggested ALL custom fields ( all 403 of them ) are now set to "translate".

However, as before, the custom field wysiwyg editor fields only show up on the English pages. They are still missing on the translated pages.

For example, they do appear on the English page:

hidden link

But they are still missing on the Portuguese page:

hidden link

Here are the WPML translate settings for custom fields for this page:

September 12, 2019 at 5:07 am #4558367

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

It seems you are editing the page right now.

I missed to add a final step, Once the ACF fields are set to translate,
Update the page in the default language, This will notify the translation about the existing custom fields to be transated.

If you dont see the fields in the translation,
- Complete the translation to 100%
- Update the page in the default language
- You should see the translation changes the status to needs update
- Now open the translation you should see the fields

Let me know if you need further assistance.

Kind regards
Raja

September 19, 2019 at 5:29 pm #4607639

jessicaT-2

Hello Raja,

We have been doing a boat load of testing and troubleshooting on this issue since we last posting anything to this ticket. We have noticed something that may be the key to solving this problem if we can understand what it means and why it is happening.

We have a staging server version that was created in May 2019 that does not have the issue. We made a copy of this to another staging server so we could do testing on it without changing the website version we know is working.

We have updated this copy to the latest WordPress 5.2.3, updated WPML, and pushed and prodded it in all manner of way, but it remains working and without the problem.

But this is the part I would like you to comment on please.

If we edit a translated page on this staging server copy ( staging 7 ) and compare it with the same page on a fresh copy of the live website ( staging 2 ) we see that an option is missing on staging 2 inside the dropdown "Screen Options" at the top of the page.

Staging 7 has the option "New Services" and Staging 2 does not!

If I uncheck "New Services" on staging 7 all the ACF editing windows disappear recreating the problem that the live website has.

So the question is, why is "New Services" missing on the live website, and where does "New Services" come from anyway? Do you recognize it?

I expect if we could get "New Services" back I problem would be solved.

Just to note, on staging 2 if WPML is disabled the missing "New Services" option comes back, and we can see the missing ACF wysiwyg editors.

I'll provide you with screenshots of the Screen Options dropdown so you know exactly what I am referring to. And I'll provide url's to the page on both staging servers along with the username and password to log into them. Just remember, you sometimes have to re-paste in the password once or twice for the server to accept the login.

Thanks so much,

Rick Stewart

Staging 7 page ( without the problem )
hidden link
hidden link

Staging 2 same page ( has problem - is missing ACF wysiwyg editors )
hidden link
hidden link

September 20, 2019 at 6:11 am #4609941

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello Rick, Thanks for the details.

Before I proceed further, For security reasons I have removed the credentials from your previous message since it is not private and anyone can easily access these details.

To be on the safer side I would request you to reset the password and send the new credentials in your next reply which I have marked as private.

Please note I won't be accessing the site until I am supplied with new credentials.

If you don't see the private form below, please don't add your credentials as they will be publicly exposed: hidden link

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

September 20, 2019 at 12:46 pm