This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Carlos Rojas 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 1, 2019 at 3:14 am #4668559

robertH-9

I am trying to: Work using English Admin

Link to a page where the issue can be seen: hidden link

I expected to see: English Gutenberg sidebar

Instead, I got: Japanese Gutenberg sidebar

* Site default language is Japanese, with English as secondary
* Profile → Personal options → Language is set to English
* Changing language on the top bar does not change Gutenberg sidebar language
* Main menu language is correct
* Happens after WPML installation

October 1, 2019 at 12:36 pm #4672043

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

October 3, 2019 at 5:20 am #4684723

robertH-9

Hi Carlos,

1. Sorry I can't do this in production environment.
Staging environment however,
- WPML 4.2.6 does not have the issue
- Uninstalled WPML 4.2.6, installed 4.2.9, issue appeared

2. Yeah this is added after I exported the information.

October 3, 2019 at 6:59 am #4684931

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I would like to request temporary access (wp-admin and FTP) to your staging site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Regards,
Carlos