This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 5, 2019 at 6:12 am #4338057

drorL

I having 404 error after install wpml.
I have done clear cache and increase memory 128.
In my site working in only the Hebrew language.

August 5, 2019 at 8:48 am #4339077

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please let me know when you are getting this error and on what page (if you can share the link of that page, too, that would help a lot)?

Can you please try this, too:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

If the steps above don't change anything, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 5, 2019 at 12:50 pm #4340637

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

From what I can see, the theme that you are using it was last tested with WPML in 2016 (https://wpml.org/theme/reales-wp/) so my guess is that there might be some incompatibility issues at the moment.

Also, after I went to WPML > Languages, and unchecked the "Use directory for default language" option, the homepage now loads up just fine (hidden link) but the 404 issue is still happening for the Russian and Hungarian versions.

1. Can you please let me know if there's any editing done for this theme that you are using? I see that you are using the child version of the theme so has there been any custom coding over what comes already with the theme package?

2. Can you please try this first and see if anything changes:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how the steps above go and if they help us to find any new information regarding the issues.

I will be waiting for your response.

Kind regards,
Mihai

August 6, 2019 at 11:12 am #4346717

drorL

I am following your step but still not working site in Russian and Hungarian language.
Please check and fixed it asap.

August 6, 2019 at 1:52 pm #4348013

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

Can you please let me know if there's any editing done for this theme that you are using? I see that you are using the child version of the theme so has there been any custom coding over what comes already with the theme package?

I am waiting for an answer from you regarding this question as it might help me better understand if there has been any custom work done and if it has, which one is that.

Please let me know.

Kind regards,
Mihai

August 7, 2019 at 4:29 am #4351983

drorL

I haven't done any custom code and am using the default twenty-seventeen theme. Here I didn't create any child theme.
Please check and solve this issue asap.

August 7, 2019 at 3:47 pm #4356573

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

I have updated the plugins and ran a few more tests but I still have no resolution for the moment.

Going forward with the debugging process, we have 2 options:

1. I will either need FTP access to run the new debugging processes

2. Or I will need you to please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

Now please try to revisit the pages that don't work.

This will create debug.log file in your site's wp-content directory. Please send me its contents through a file sharing service like dropbox or google drive.

I will be waiting for your response.

Kind regards,
Mihai

August 8, 2019 at 6:13 am #4359937

drorL

Hi Mihai Apetrei,
this is debug.log file link in google driver hidden link
Please check and solve all the wpml plugin issue.

August 8, 2019 at 7:29 pm #4365625

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the debug log.

After all the investigation, it seems that there is an issue with the Russian and Hungarian languages whenever the "Different languages in directories" option is used inside WPML > Languages (hidden link).

I went to WPML > Languages and switched that to "Language name added as a parameter" and the languages work perfectly, all of them. You can see them working on the site right now:

- hidden link
- hidden link

This will require a deeper investigation and I will need to get in touch with some of my colleagues from the developers' team and have them dig deeper to find out why "Different languages in directories" doesn't work.

To further debug the problem I’d like to replicate your site locally.

I will need your written approval to be able to duplicate your site using a plugin called "Duplicator" and test your site on a local environment so can you please let me know if this is ok with you?

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 9, 2019 at 9:04 am #4368865

drorL

Hi Mihai Apetrei,
Yes, you can add the Duplicator plugin and start to debug the problem.

August 9, 2019 at 3:41 pm #4371719

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Thank you for the confirmation.

I will keep you updated as soon as I have more feedback regarding this.

I don't work on the weekends so I will be able to get back to you next week regarding this.

For the moment, the site is using the "Language name added as a parameter" option so that the languages work.

Kind regards,
Mihai

August 13, 2019 at 9:58 am #4386833

drorL

Any update on this?

August 13, 2019 at 6:22 pm #4390241

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for your patience and I am sorry that this takes so long.

Unfortunately, this issue requires more in-depth analysis than a standard one that can get resolved in two-three replies.

I am also waiting for an answer from some colleagues and I will get back to you tomorrow with more feedback and insights on this.

I am leaving the ticket assigned to myself for the moment.

Kind regards,
Mihai

August 14, 2019 at 8:19 pm #4397319

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience once again.

After digging deeper, I realized that inside the .htaccess file inside your WordPress install folder on your hosting plan, you had this line at the beginning of the file (I am attaching a screenshot).

I could not see this until now as I had no FTP access (and I also didn't think of it as I know that you confirmed there was no custom code used on the site), but I used a plugin that allowed me to check the .htaccess file and I found that.

Due to this piece of code, you were experiencing that issue with the Russian and Hungarian language links, so I removed it for the moment.

Now, both of them work:
- hidden link
- hidden link

Can you please confirm that the issue is resolved and works from your side, too?

I will be waiting for your response to find out if you still need assistance 🙂

Kind regards,
Mihai

August 20, 2019 at 12:28 pm #4423553

drorL

Hi
After debugging my all post-show in English another languages post is empty.
for example, See my new and old site screenshots.
This issue shows after debugging by your end.