Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by emreG-3 2 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
September 2, 2019 at 8:38 pm #4499937

emreG-3

Hello,

I have issues when creating a page in german. Let's say the English URL is /new-york

the german URL is automatically being /de/new-york-2.

I have read the other topics in the forum, enabled/disabled the plugins, cleaned the cache and did not work.

September 2, 2019 at 11:21 pm #4500161

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. This is usually a standard WordPress behavior, as it does not allow two identical slugs at first.

As a suggestion, you can simply edit the slug and remove the "-2" in the secondary language. To do this, just go to the page where the posts/pages are listed and switch to the secondary language. Then click "Quick Edit" and edit the slug according to your needs.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

September 3, 2019 at 11:07 am #4503813

emreG-3

Hello Bruno,

I hope you are not joking about the answer you have provided. As I said before, I have tried to change it, next to that, I have enabled/disabled plugins as well as the theme. It does not work.

September 3, 2019 at 5:55 pm #4506747

emreG-3

My issue is resolved now. Thank you!