This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Laura 5 months ago.

Assigned support staff: Laura.

Author Posts
May 4, 2019 at 8:26 am

keizerO

I am trying to: Have latest woocommerce update

Link to a page where the issue can be seen:hidden link

I expected to see: non broken website

Instead, I got:
After activating Woocommerce Multilingual this error pops up and I cannot use the website:
"Fatal error: Uncaught Error: Class 'Dokan_Stripe_Connect' not found in /www/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-wc-gateways.php:48 Stack trace: #0 /www/wp-includes/class-wp-hook.php(286): WCML_WC_Gateways->loaded_woocommerce_payment_gateways(Array) #1 /www/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #2 /www/wp-content/plugins/woocommerce/includes/class-wc-payment-gateways.php(85): apply_filters('woocommerce_pay...', Array) #3 /www/wp-content/plugins/woocommerce/includes/class-wc-payment-gateways.php(70): WC_Payment_Gateways->init() #4 /www/wp-content/plugins/woocommerce/includes/class-wc-payment-gateways.php(43): WC_Payment_Gateways->__construct() #5 /www/wp-content/plugins/woocommerce/includes/class-woocommerce.php(773): WC_Payment_Gateways::instance() #6 /www/wp-content/plugins/woocommerce/includes/class-woocommerce.php(146): WooCommerce->payment_gateways() #7 /www/wp-content/plugins/yith-stripe-connect-for-woocommerce-premium/includes/class.yith-stripe-connect-api-handler.ph in /www/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-wc-gateways.php on line 48"

May 4, 2019 at 1:00 pm #3740341

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

This was your first-time install or you were just updating WCML?
The error seems to relate to Dokan plugin, which should be WPML compatible.

Maybe some file was corrupted during installation/update.
Could you retry, possibly doing a manual install?

-Backup your site and database
-Deactivate and delete the “installer” plugin (if you have it).
-Deactivate all WPML plugins.
-Login via FTP to your wp-content/plugins/ folder.
-Delete all WPML folders.
-Go to http://wpml.org/my-account/downloads/ and download the latest WPML Multilingual CMS Plugin, then extract it.
-Upload the plugin via FTP to wp-content/plugins/ folder.
(alternatively you could upload the .zip folder using Dashboard > Plugins > new > upload)
-Activate the WPML plugin via WP Dashboard > plugins.
-Complete the setup, if needed.
-Register WPML for your site (at the end of setup, click on “generate key” button).
-Navigate to Dashboard > Plugins and locate WPML Multilingual CMS.
-Click on the blue link that says “Registered”.
-Download and activate all needed WPML AddOn Plugins.

This should not generate any problems.
Let me know if this helps you or if you need further assistance.

May 9, 2019 at 9:06 am #3774403

keizerO

Hi,
I followed the steps but even after that I am still getting the issue.
Activated all add-ons one by one and I just noticed that the error appears after activating the String translation add-on.

May 10, 2019 at 8:15 am #3782127

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

could you try to disable YITH Stripe Connect for WooCommerce and see if the error disappear?

May 13, 2019 at 9:25 am #3796461

keizerO

Hi,
I deactivated the YITH Stripe Connect for WooCommerce Plugin and the error disappears, but I also need that plugin.

May 13, 2019 at 12:15 pm #3797995

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

if we know which plugins caused it we can test for compatibility. Could you try to reproduce the issue here? hidden link

You need to install YITH Stripe Connect for WooCommerce and see if you can recreate the same error.

May 14, 2019 at 1:16 pm #3807169

keizerO

Hi,
I installed the Yith Stripe Connect and Dokan Plugin because it looks like it has something to do with the conflicts, but after that, when I was finishing the WPML setup the sandbox just crashed and gives me a "HTTP ERROR 500" error and I am not able to acess it anymore.

May 15, 2019 at 6:25 am #3812517

keizerO

Hi,
I found out that the issua was related to Dokan's module and I've disabled it.

May 15, 2019 at 9:47 am #3814573

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

so the issue is only with Dokan or YITH is still involved? Do you want me to further debug the issue?

May 15, 2019 at 1:06 pm #3816687

keizerO

Hi,
I think the problem as something to do with Stripe Connect Plugins, because both Dokan and Yith have plugins for that and both of them where installed and enabled on the website when the bug ocurred, but when I disabled one of them OR WPML String Translation everything worked fine.
For now I have disabled the Dokan Stripe Connect Plugin and everything works fine. I've submited a ticket to them since the main reason for the conflict was their module, so I think there's no need for further debug.
Thank you very much for the attention.

Have a nice day

May 15, 2019 at 1:25 pm #3817021

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Ok, thanks for letting me know.
Please come back to us if you still need help with this issue.