If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Radu 4 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
July 5, 2019 at 11:15 am

rickardR-2

I am trying to:
I there,
I am translating from English to Norwegian and everything was working fine until the header bar for the translated pages in Norwegian disappeared.

I have been looking into why and think I must have ticked something wrong since I had my translated header menus up until now. it happened after the translation of theme builder content. Yes, I use Elementor to build the header.

Would you be able to tell me what is the most obvious reason for this. Below are a link to the original English language main page (home) and the Norwegian one (Meny). So you can see what I am talking about.

Your help is much appreciated.

Think was a similar issue here: https://wpml.org/forums/topic/header-bar-disappeared-on-translated-pages-only/

Thanks,
Rickard

July 5, 2019 at 11:27 am #4150779

rickardR-2

Here is another image regarding the header.

July 8, 2019 at 7:50 am #4159625

rickardR-2

The Elementor team said this:

"Thanks for contacting us.

There are conflicts of Global widgets and display condition at the moment with WPML.

The translation of the templates of the theme builder of Elementor (header, footer, single post templates, etc...) works only when the "display conditions" setting is set to "entire site".
The theme builder compatibility was supposed to be fixed by:
https://wpml.org/he/2018/07/wpml-4-0-5-with-support-for-elementor-templates-and-global-widgets/
but this issue with the "display conditions" which does not work when the template is not applied to the entire site is still on.

The translation works only if the header/footer is assigned to the entire website:
https://wpml.org/forums/topic/elementor-new-footer-template-wpml/

We did some adjustments a few months ago to enable WPML to make the necessary compatibilities. Right now it's in their own territory.

Let me know if you need any additional assistance.
Let me know whether this helped you."

I hope it will be helpful to finally get the website online, after a lot of work and technical issues.

July 9, 2019 at 12:41 pm #4170843

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Rickard,

As I can see, you opened a new ticket about this issue right here: https://wpml.org/forums/topic/elementor-templates-lose-the-instances-attachments-after-translation/. Can you reply back on it with the informations that my colleague asked for, please? This way, we'll be able to report everything to the development team and they will check this compatibility issue.

Thanks,
Radu

The topic ‘[Closed] Header bar for the translated pages in Norwegian disappeared.’ is closed to new replies.