Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Izzi Hassan 3 months, 3 weeks ago.

Assigned support staff: Izzi Hassan.

Author Posts
October 28, 2019 at 11:30 am #4838855

tobiasM-27

I am trying to: I updated the H3 header css in the theme options. While the change reflects in the original language (EN) the translated (DE) still shows the previous style.

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
The same H3 font settings in both pages

Instead, I got:
The original shows the new H3 font settings while translated (DE) page still shows the former settings.

October 29, 2019 at 6:35 pm #4851083

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for reaching out to WPML Support.

It looks like you're using the Avada theme. Avada is WPML compatible and the H3 font settings are set up to be the same for all languages by default.

I took a look at the links you provided and was not able to see a difference in the H3 tag fonts. Could you clarify if the issue still persists, or maybe you fixed it manually?

Thanks!

October 29, 2019 at 7:23 pm #4851311

tobiasM-27

On 2 different machines with 3 different browsers I still see 2 different H3 fonts:
hidden link
has 16px font size with 5px spacing while
hidden link
has 18px bold font with normal spacing.

October 30, 2019 at 5:46 am #4852675

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Tobias,

I apologize. I must've made a mistake since I do see different fonts now.

This is expected behavior due to the reason that Avada theme options are meant to be individually customizable for each language.

To fix your immediate issue, you can go to the Avada -> Theme Options page and choose your secondary language (DE) from the language switcher at the top of the page as shown in the screenshot.

Any updates to the Theme Options will now be applied only to the translated pages.

IMPORTANT
Please make a backup of site files and database before trying the steps below. Backing up your website ensures that you will be able to recover it in case something goes wrong. We always recommend trying any significant changes in a development, or staging, environment before applying them to a production website.

At the very least, please back up your Avada settings by following these steps:
- Go to the Avada -> Theme Options page
- Select Import / Export from the tabs
- Click the Download Data File button

To use the same theme options for all languages, you must:
- Go to the Avada -> Theme Options page
- Select All Languages from the language selector at the top of the page
- Select Import / Export from the tabs
- Click the Import contents from file
- Copy your downloaded settings into the box
- Click the Import button

To change theme options for all languages, you must:
- Go to the Avada -> Theme Options page
- Select All Languages from the language selector at the top of the page
- Make your changes

Please do let us know if this helps you resolve your issue, and don't hesitate to reach out again if you need further assistance with this topic!

October 30, 2019 at 6:36 am #4852723

tobiasM-27

Thanks! WPML has more flexibility than I expected. That worked!

October 30, 2019 at 6:39 am #4852729

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I'm really glad that helped!

I'm sorry that I didn't catch that yesterday and offer you a more timely resolution. WPML is quite flexible and reliable when used with a theme like Avada.

Please do not hesitate to reach out again if you have further issues with any use case!