This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The header is broken in Russian and Turkish languages on each product's pages

Solution: I followed this steps:
- WPML -> Settings -> Custom XML Configuration tab -> Added the following code:

<wpml-config>
    <admin-texts>
        <key name="woodmart_options">
            <key name="single_product_header"/></key>
    </admin-texts>
</wpml-config>

- Then I went to WPML -> String Translation -> Searched 'none' under 'admin_texts_woodmart_options' domain and added as translation the same word ('none' in all languages).

Relevant Documentation: You can find more information about Language Configuration Files in: https://wpml.org/documentation/support/language-configuration-files/

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 7, 2019 at 7:42 pm #4357805

atakanI

Hello,

I created an online florist website in English and I started to translate all of my products and pages into Russian and Turkish until I realize that the header has been broken on product pages in translated languages pages. I mean everything is fine on the main page, category pages in all languages. But the header is broken in Russian and Turkish languages on each product's pages.

Can you help me, please?

August 8, 2019 at 12:03 am #4358657

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

3.- Please update all outdated plugins and themes, specially WPML plugins. Outdated functionalities can cause conflicts in the code.

Kind regards,
Carlos

August 8, 2019 at 10:20 am #4361763

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Could you describe the steps to follow in order to edit the header?

Regards,
Carlos

August 8, 2019 at 10:50 am #4362031

atakanI

Hello Carlos,

I am going to explain my problem and what I have done so far with your WPML plugin.

Let's have a look at an example. Got to "35 Heart Shaped Red Roses Box" specific product page. (hidden link) The header is what I want to.

When I change the language at that specific product pages in Turkish or Russian, header switching into theme default logo and menus are going down. (hidden link)

The main page and product pages seem fine in all languages. I have no idea when it occurred because It only occurs in product pages in Turkish and Russian languages.

When I realize:

I started to change "translation strings" I added a couple of translations till "woodmart" section in translation strings. But to solve the problem I deleted some of the translations.

I checked the header options in different languages. But do you know what? The problem just occurs in product pages in Turkish and Russian.

I am kindly asking you to take care of my problem fast. And please focus.

August 8, 2019 at 11:21 am #4362199

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I followed this steps:
- WPML -> Settings -> Custom XML Configuration tab -> Added the following code:

<wpml-config>
    <admin-texts>
        <key name="woodmart_options">
            <key name="single_product_header"/></key>
    </admin-texts>
</wpml-config>

You can find more information about Language Configuration Files in: https://wpml.org/documentation/support/language-configuration-files/
- Then I went to WPML -> String Translation -> Searched 'none' under 'admin_texts_woodmart_options' domain and added as translation the same word ('none' in all languages).

Could you confirm that the issue is solved?

Regards,
Carlos

August 8, 2019 at 11:29 am #4362223

atakanI

Thank you very much, Carlos. The problem is solved thanks to you.

So you claim that the problem occurred because of the translation of "none" word. We translated into different languages and the problem occurred. Am I right?

I am trying to understand which strings we should not touch.

August 8, 2019 at 11:33 am #4362233

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Yes, in this case the word 'none' is an option that shouldn't be translated because it is used by the theme to compare which header to show for single products.

This means that to print the single product, the theme check if the option is set to 'none' and if you translate this string then the comparison will be always false.

Regards,
Carlos

August 8, 2019 at 11:37 am #4362241

atakanI

My issue is resolved now. I understand everything. Thank you very much Corlos!

September 1, 2019 at 10:53 am #4492421

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos