This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 month, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 29, 2019 at 7:47 pm #4483327

gordanM

I am trying to: get right header

Link to a page where the issue can be seen: hidden link

I expected to see: view before installing WPML

Instead, I got: widerheader

August 29, 2019 at 11:44 pm #4483761

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It happens due the way your theme handles the space available in your header to wrap a long navigation, when you insert the language switcher in the main navigation your header try to accomodate it and then you see the issue as the header doesn't have enough space for that. You can try two things:

1 - Make the font of your menu items smaller, currently they are 20px size, you can try it with 15px size for example. For that you can enter some custom css code in your WordPress Dashboard > Appearance > Customize > Additional CSS. Here is a sample code:

.fusion-main-menu>ul>li>a {
font-size: 15px!important;
}

2 - Make the language switcher appears as dropdown menu instead of a list of languages from your WordPress Dashboard > WPML > Languages > Menu language switcher settings.

See: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please, let me know if it helps, have a nice day.

August 30, 2019 at 5:28 am #4484753

gordanM

Hi, thank you but it doesn't work even if I don't want smaller font or drop down menu. The header is still wide.

August 30, 2019 at 5:43 pm #4488625

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 30, 2019 at 8:12 pm #4489131

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I've just made a test without the WPML Language Switcher and the issue persists, it indicates the cause of your issue is not the language switcher itself, instead it is related your current header setup. I noticed your header has a dynamic height calculated according the space and items inserted on it, I think here the way your logo is setup cause this kind of issue.

Please, review your header layout settings in order to fix it. Thank you for your understanding and collaboration, have a nice day.

August 30, 2019 at 8:21 pm #4489139

gordanM

How can you explain the fact that I have set up the logo and and header three months ago and everything was OK until I set up the language switcher?

August 30, 2019 at 8:50 pm #4489185

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. For test purposes you can temporary disable the WPML plugin and test your header again, it will confirm for us if WPML is interfering in your header layout. Please, let me know the results. Have a nice day.

September 2, 2019 at 9:42 am #4495837

gordanM

I'm sending you two files. One before installing switcher and one with switcher. Don't tell me that something is wrong with the logo. If you can not bring it in the former state there is no need for the further conversation.
thanks

September 2, 2019 at 6:17 pm #4499625

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Did you test it with WPML disabled? In any case, the custom CSS code is the workaround I found to make your header keeps the previous height regardless of the WPML Language Swticher usage, here is the code:

.fusion-header {
	height: 80px!important;
}

.home .fusion-header .fusion-logo {
	position: absolute!important;
}

I placed this custom code in your WordPress Dashboard > Appearance > Customize > Addicional CSS

Please, let me know if you need any other details, have a nice day.