This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Noman 3 weeks, 3 days ago.

Assigned support staff: Noman.

Author Posts
September 19, 2019 at 8:32 pm #4608247

webisW

I created a primary menu translation according to the doc. Everything works fine but for some reason, primary menu for translated language is empty on home page.

September 19, 2019 at 9:28 pm #4608325

webisW

After a bit of investigation, I noticed that if I don't have my home page translated, the translated menu shows up. If I have my translated home page, then, menu is missing like the screenshot above.

September 22, 2019 at 2:08 pm #4618725

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,
Thank you for contacting WPML Support.

1. Could you please make sure you have followed our step by step guide for menu translation:
https://wpml.org/documentation/getting-started-guide/translating-menus/

2. Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search your theme in this list. https://wpml.org/documentation/theme-compatibility

3. Please clear all sort of caches in your site plugin cache / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

4. Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

5. If still issue persists, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/
Thank you

September 23, 2019 at 6:29 pm #4626131

webisW

I have tested on a default theme with only WooCommerce & WPML plugins, but menu is still empty on translated language's home page.

September 24, 2019 at 5:34 am #4628079

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 26, 2019 at 5:01 pm #4649183

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have logged in to your site and checked plugin conflict in your site. The issue is gone when I deactivated ‘WooCommerce Onsale Page’ plugin.

Also I couldn’t find ‘WooCommerce Onsale Page’ plugin in our verified compatibility plugin list:
https://wpml.org/documentation/plugins-compatibility/

I recommend you to please ask ‘WooCommerce Onsale Page’ plugin author so they can advise you on latest compatibility of their plugin and WPML, may be they have a fix for it, so it should work fine with wpml.

Thank you for your cooperation and patience.