Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by joepF 6 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
April 20, 2019 at 4:01 pm #3650623

joepF

I am trying to: get the header urls not display

Link to a page where the issue can be seen: hidden link

I expected to see: nothing in top header

This happens sometimes, not always

April 21, 2019 at 10:16 am #3652063

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have tried to open this link:
hidden link
In Chrome/Firefox browsers multiple time but I couldn’t see any URL in header as you have shown in your screenshot.

- Please clear all sorts of caches in your site plugin cache / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards. OR check the page in another browser.

If issue still occurs after trying above, could you please let me know the steps to reproduce this issue? Thank you

April 27, 2019 at 7:18 am #3694759

joepF

Hi! It is not the cache, I already disabled all caching. If you navigate through the menu and different pages sometimes, the problem appears. Can you try again and help me solve it?

April 28, 2019 at 11:11 am #3697801

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for more details. Yes, I can see the issue now. Could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

- We have released updated version of WPML plugins. Can you please take a backup of your site and update ALL WPML plugins.

- Please make sure you are using an updated version of the theme.

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

May 1, 2019 at 11:13 am #3717749

joepF

Hi!

I added the code to the WP config file. Very strange, but now the issue appears on even more pages and more often. I also updated all the software and approached Elegant Themes support (divi) but they said it was not a problem on their side.

Can you help me out?

Thanks alot.

May 2, 2019 at 9:54 am #3723517

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug language switcher dropdown width issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 2, 2019 at 5:42 pm #3727867

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. I have logged in to your site and checked theme conflict by deactivated child theme and activated parent Divi theme. The issue is gone after deactivated child theme in your site.

Above step clearly state that issue was coming from your custom theme and not from WPML.

Then I examined your custom theme and found out that there was some echo statement that causing this issue. I have commented out that line and issue is gone.

Could you please check and confirm?

Thank you

May 2, 2019 at 8:28 pm #3729073

joepF

My issue is resolved now. Thank you!

May 5, 2019 at 3:12 pm #3743199

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

[ Ticket status changed ]

May 6, 2019 at 8:41 am #3745935

joepF

Thanks a lot!