We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Patty Brummelman 5 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
May 14, 2019 at 10:32 am #3805929

Patty Brummelman

I am trying to: Translate a headline

Link to a page where the issue can be seen: hidden link

I expected to see: In the backend I expected a field for the headline (in this case "ONZE KLANTEN" and "ONZE NIEUWSTE PRODUCTEN" ) when I translate the page using WPML's Translation Editor

Instead, I got:
No option to translate these headings

May 14, 2019 at 12:31 pm #3806759

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Can you please tell me which type of element you are using to create these headlines? It looks like you are using the WP Bakery Page Builder, which is not yet fully compatible with WPML, so this may be the reason the headlines are not showing up. It may be that the element needs to be added to the wpml-config.xml file. If you are able to view the code for the page, you may be able to locate the shortcode for this field and add it to WPML -> Settings -> Custom XML Configuration.

May 15, 2019 at 1:16 pm #3816799

Patty Brummelman

Hi Lauren! The type of element is called "Headline". And yes, I am using WP Bakery Page Builder.

Once I find the shortcode, what do I need to put in the XML? I already have the follwoing, but these are all copy. i want to translate this one.
<wpml-config>
<custom-fields>
<custom-field action="copy">_header_bg_img</custom-field>
<custom-field action="copy">_wolf_slide_image_img</custom-field>
</custom-fields>
</wpml-config>

Thanks in advance!

May 15, 2019 at 1:34 pm #3817077

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

If the content is created in a shortcode used by the page builder, then you will want to add it according to the instructions here: https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

Otherwise, if it is a custom field versus a shortcode, then you can use the same code you posted above but change "copy" to "translate".

Please let me know if you need any further assistance and I will be happy to help.

May 16, 2019 at 12:08 pm #3825715

Patty Brummelman

I got it working in the back end with the short code. I now can add a translation. I added it and set it to translation complete.

However, in the front end it's still showing the original language. I emptied cache, also tried incognito mode and a different browser, but no change.

May 16, 2019 at 6:04 pm #3828689

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

May 17, 2019 at 3:26 pm #3835657

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for sharing credentials. I found that the titles for the sections are stored in the page builder strings. You can go to WPML -> String Translation and search for the header and translate it there. Just be sure to mark it as complete and click Save. I tested this with the Spanish translation and it displayed correctly on the frontend. I have since removed my test translation.

May 17, 2019 at 7:39 pm #3836707

Patty Brummelman

I did find the translations there and was able to put them in. However, I now noticed that for that same page, the English and Spanish translations can be done from the page dashboard, but with the German and French translations, not all fields are shown anymore. They were shown in Dutch on the website, and was able to translate those too via String Translation.
How come the normal translation option are not all available in those 2 languages?

May 17, 2019 at 8:13 pm #3836827

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Please let me know if this resolves the issue.

May 30, 2019 at 11:04 am #3922445

Patty Brummelman

Hi Lauren, i added these lines, but it didn't help. I there something else I need to do?

May 30, 2019 at 11:04 am #3922451

Patty Brummelman

I will start a new thread with this question, thanks