This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 11 months, 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 15, 2018 at 11:42 am #2817195

michalB-2

The Hebrew strings are shown With the UK flag next to them and the translation is offered to Hebrew, also on the checkout the shipping methods are in Hebrew even the site is on English.
In the Hebrew site "Shipping" and "I have read and agree to the website" are in English

October 16, 2018 at 9:38 pm #2822459

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- In order to change the language of the strings you need to follow this steps:
- Go to WPML -> String Translation -> Select the strings in the wrong language using the checkbox at the beginning of the row -> Use the button under the search result table to change the language of the string(s).

Could you confirm that the issue is solved?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

October 18, 2018 at 7:25 am #2826945

michalB-2

I need to check all the string?
what is define as "slug" it is for the URL?
The "Shipping" and "I have read and..." are still not translated.
I using flatsome as theme (do remember if wrote this)
I used this code

define('WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

It is good?

October 18, 2018 at 4:33 pm #2828838

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

1.- Yes, the slug is defined for the URL. In this link you will find more information about the slug: hidden link

2.- Regarding this two untranslated strings, do they appear in String Translation?

Note: The code added is correct 🙂

Regards,
Carlos

October 22, 2018 at 5:47 am #2836826

michalB-2

I change the setting and I it work for now.

October 22, 2018 at 5:07 pm #2839109

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos