This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 3 voices.

Last updated by bouhafsia 3 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
May 29, 2019 at 11:49 pm #3919059

bouhafsia

Tell us what you are trying to do?
Hello , i have a problel with my home page transaltion , i translated all string , but i can't got the home page , but instead i have a 404 page !!
the whole home page is hiden.

May 30, 2019 at 7:02 am #3920839

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. Please re-save permalink by pressing ‘Save Changes’ button from Settings >> Permalinks and see if this resolve your issue:
https://codex.wordpress.org/Settings_Permalinks_Screen

3. Could you please clear all sort of caches in your site plugin cache (W3 Total Cache) / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

4. Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search your theme in this list. https://wpml.org/documentation/theme-compatibility

5. Also make sure you are using an updated version of the theme and plugins.

6. Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If the issue is gone, activate one by one to see which one there is an interaction issue.

Please let me know the results.

Thank you

June 2, 2019 at 4:05 pm #3937701

bouhafsia

Hello sir , I followed your steps , but still can't get my home page translated !

June 3, 2019 at 6:06 am #3939501

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 4, 2019 at 9:07 am #3949455

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Noman is on vacation now. So I am taking care of this ticket. Hope it will be okay for you.

Thank you for the login information. You are having this issue because the Homepage translation is completed to Arabic yet. Please complete the translation and make sure you are getting the expected result or not.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

June 4, 2019 at 11:53 pm #3955785

bouhafsia

Hello sir ,
Thank your for your assistance ,
I already check this point i am in 100% of the translation of the home page ,

June 5, 2019 at 3:22 pm #3962289

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The system still shows the translation is not complete yet. Please try the following steps after a backup and check you are getting the expected result.

1) Once again visit the Advanced Translation Editor and finish the translation
2) Go to WPML>>Settings click on *Synchronize translators and translation managers* button of *How to translate posts and pages* section
3) Visit WPML>>Translation Management>>Translation Jobs, choose the Homepage from the translation job list. Then choose *Get translations* click on *Apply* button.

Please check the attached images for more details.

--
Thanks!

Bigul

June 5, 2019 at 4:13 pm #3962661

bouhafsia

Hello sir for this step , i have a problem , i can't see the button for the second step , "2) Go to WPML>>Settings click on *Synchronize translators and translation managers* button of *How to translate posts and pages* section"
i tried to change the navigator , i am using chrome and i tried mozilla firefox , the same problem can't see the button !

Thank you sir for your support ,

June 5, 2019 at 5:58 pm #3963275

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following step and check is there any difference in the result.

Visit WPML>>Translation Management>>Translation Jobs, choose the Homepage from the translation job list. Then choose *Get translations* click on *Apply* button.

--
Thanks!

Bigul

June 5, 2019 at 6:12 pm #3963337

bouhafsia

Hello sir , thank you for your support ,
So I tried this step , as you mentionned in your ansewer , but nothing happen when i press the button apply to get the translations ,
waiting for your answer sir , thank you

June 6, 2019 at 6:23 am #3966019

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following steps and let me know your feedback.

a) Visit WPML>>Translation Management>>Translation Roles, make sure you have added as a Translator and Translation Manager

b) Visit WPML>>Settings to sync the translation settings

c) Open the Homepage for translation in Advanced Translation Editor

d) Do minor edit to translation and finish the translation

--
Thanks!

Bigul

June 7, 2019 at 6:22 am #3974167

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have a couple of requests to track the issue.

a) Create a new Page or Post in French, then try to translate it to Arabic and make sure the issue is existing or not

b) Please share with me the WordPress debug.log (not WPML debug information) for more details.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

June 7, 2019 at 2:20 pm #3977023

bouhafsia

Hello sir , thank you for your reply & support ,
I created a new page , i make a translation for this page , i repeated the same steps as befor , but still can't get the tranlsations for this page !!
now i followed your steps i created , for you this log , this the Url : https://pastebin.com/BkhNNJCP

June 7, 2019 at 6:23 pm #3978425

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

June 7, 2019 at 6:30 pm #3978509

bouhafsia

Hello Sir , No Problem for me , but how i can Allow you ?
what i need to do for that sir ,
Thank you ?