This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by דנאי כתב 6 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
January 31, 2019 at 8:53 am #3146705

דנאי כתב

I tried to find the URL of the logo to translate it to from Hebrew to English, but I didn't find it.

Reading Similar tickets, I noticed I have a WPML config file only on my Parent Theme, and not on my Child Theme.

I would appreciate the help...

January 31, 2019 at 9:23 am #3146910

דנאי כתב

I found the logo URL string in the "Translate texts in admin screens" list and Pressed Apply, but I still don't find it in the String Translation search results.

January 31, 2019 at 12:50 pm #3147917

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

After pressing ‘Apply’ button, newly enabled strings should be available on top of the string translation page.

In most cases a string is not enabled and this is due to too many options being saved at once on that page. To fix this issue, please increase MaxInputVars to 10000 or more. For this, please try to set this variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

2. After increasing max_input_vars value you need to tick all the required strings from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> and click on “Apply” button.

Then please go to WPML >> String Translation and you will see newly enabled values at top of the page and ready for translation, add the translation for those strings and check Translation is complete checkbox and press Save button.

Please try it and let me know what happens after you have enabled that string and string is marked as “Checked” on Translate texts in admin screen.

Thank you

March 7, 2019 at 6:03 pm #3286290

דנאי כתב

Dear Noman, We had alot of work in the office and just today I followed your instructions regarding this issue.

I set the 3 vars in the php.ini file, and tried to add the logo-url field to the translated strings list.
But although I found it in the list "Translate texts in admin screens »" It was not added to the traslated strings list as I wished.

I hope I really set those 3 vars in my website, SiteGround Support helped me. At first the supporter told me I can just add 1 of them, then I added the other 2 myself, and finally another supporter told me that all 3 of them were added successfully.

Is there a way to check it?

Thank you,
Gal Saggie

March 9, 2019 at 7:49 am #3297240

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

You can check updated values from WPML >> Support page as you can see in attached screenshot.

Thank you

April 11, 2019 at 9:22 am #3585571

דנאי כתב

Hello Noman,

As I said in my previous message, I didn't succeed in adding the logo URL to the translated strings list.

I contacted my hosting provider, to verify that these 3 values
max_input_vars
suhosin.post.max_vars
suhosin.request.max_vars
are set as you directed.
They checked again and said that they are set, and also sent me this image below, and also showed me the information in this link:
hidden link

In my WPML PHP info I can still see max_input_vars=3000.

What do you think is the solution for this logo translation issue?

Thanks and Regards,
Gal.

April 11, 2019 at 12:22 pm #3587315

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 18, 2019 at 6:38 am #3636355

דנאי כתב

Hello Noman,

The site has already went live, and my manager prefers not to make any changes in the website now.

I managed to change the logo to another language by CSS:

/* add style to help replace to english img */
#header .logo .logo-img img {
display: block;
-moz-box-sizing: border-box;
box-sizing: border-box;
width: 188px;
height: 101px;
}

/* replace logo img in english */
html[lang="en-US"] #header .logo .logo-img img {
background: url(ogo_english_full_url) no-repeat;
padding-left: 188px;
}

Thank you for your help,
Gal

April 18, 2019 at 6:40 am #3636357

דנאי כתב

My issue is resolved now. Thank you!