This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 10, 2018 at 9:53 am #2719496

paoloM-43

hello I translate the menu on my site: hidden link italian and english but for the moment I could see just the eng menu... the italian isn't visible... why?

September 10, 2018 at 12:02 pm #2719834

paoloM-43

this is the italian menu something in it is wrong cos the menu could be in italian not english

September 11, 2018 at 6:44 am #2722582

paoloM-43

I need to know why I could see just the italian menu on my site: hidden link. I did the italian ones and the english aswell... please let me know asap...

September 11, 2018 at 3:32 pm #2724476

paoloM-43

Hi! I need to know why the plugin is not valid or not registered. Iattached for your the view of the plugin page in Wp

September 11, 2018 at 6:36 pm #2724930

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for writing us!

I will be happy to help you with this.

I will need you to follow these steps and see if they solve your issue:

1. Go into the SG Optimizer settings, clear the cache and then disable Memcache + Dynamic cache
2. Go into the Autoptimize settings and clear the cache
3. Now please do a page refresh and see if the menu is showing up

Please let me know if this solved the issue where the appropriate menu is not displayed.

For the second question, this documentation link is exactly what you would need to register your site: https://wpml.org/faq/install-wpml/#register.

If you need more help regarding the registration process, please open a new ticket. If you wish you can assign the new ticket to me.

September 12, 2018 at 7:10 am #2726289

paoloM-43

Hi,
I purged the cache on the sg optimizer setting, I cleared the cache on the Autoptimize aswell, I refreshed the page but I could see only the italian menu... if I change the directory in hidden link the menu is in italian aswell... it seems like something is wrong... please let me know how to insert the english menu... I attached for you 2 pictures of menus...

September 12, 2018 at 9:42 am #2726968

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

The screenshots seem correct.

From your answer, I can understand that you cleared the cache for both plugins.

Can you please tell me if you also managed to disable Memcache and Dynamic caching?

September 12, 2018 at 9:50 am #2727034

paoloM-43

I attached for you a screenshot of the sg optimizer settings on my site hidden link.

September 12, 2018 at 9:54 am #2727061

paoloM-43

I also disable the Autoflush cache

September 12, 2018 at 10:10 am #2727108

paoloM-43

If you need I could create a new user to enable you to enter on the site and verify what I did. Please let me know asap.

September 12, 2018 at 10:58 am #2727221

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

To further debug the problem I’d like to replicate your site locally.

I would need a site snapshot if possible.

We usually recommend the free Plugin “Duplicator” for this purpose.

If you already know how Duplicator works (https://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the archive file you downloaded.

★ Duplicator Instructions
hidden link
https://wpml.org/faq/provide-supporters-copy-site/

If the file is too large (more than 300M), please use the Duplicator file filters to remove the cache, the wp-uploads directory, the media and the archive files.

Send me the link to the archive file (you probably want to use Google Drive, Dropbox, or similar services, as the snapshot file will be quite big).

Your next reply will be private, which means that only you and I will be able to see it and have access to it. You can paste the link to the file there. You can also share the credentials to your website. I will then download the file from the admin panel.

Once the problem is resolved I will delete the local site.

Please let me know if you need help creating the Duplicator package.

I will also need access to the current site in order to test a few more things.

I will be enabling the private fields so that the information you add won’t be shown.

September 12, 2018 at 3:16 pm #2728058

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello,

Unfortunately, when I tried to log in, I got locked out temporarily (I will attach a screenshot, too).

I will activate the private field once again for providing site access and maybe you can provide me with other credentials that we can try and see if they work this time.

Another option would be to temporarily disable Wordfence.

September 13, 2018 at 7:24 am #2730394

paoloM-43

Could you try another time... I reckon now is unblocked

September 13, 2018 at 7:34 am #2730404

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I tried yesterday to login with the new credentials but it would not even show me the username and password fields. All I could see was the same Wordfence locked-out notification.

I tried again just now, after you wrote and this time I was able to see the username and password fields but right after I entered each of them in the right field and tried to sign in, I got locked out again.

I think disabling Wordfence might help, just for the time we create a Duplicator package and test a couple things.

September 13, 2018 at 7:40 am #2730444

paoloM-43

Hi, I create a new account but I need to send you as a private massage

The topic ‘[Closed] hello I translate the menu on my site: italian and english but for’ is closed to new replies.