Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Dražen Duvnjak 7 months, 1 week ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
October 27, 2020 at 3:20 pm #7318225

martinH-16

Hello, same problem as yesterday but I finally found what is happening.

October 27, 2020 at 8:56 pm #7320757

martinH-16

Man! Thats the way! It works. So the problem is, that we dont use any content in gutenberg editor? And when we change only the ACF fields, the translation do not update?

October 28, 2020 at 10:19 am #7324385

martinH-16

Hey, so it looked like it works, but I am facing another issue. I did completely translated the page, I also have globally selected ct_other_template custom field to copy, but it does not copy the template on these pages:

hidden link
hidden link
hidden link
hidden link

what is wrong? It works on other pages.. it is really strange how this software works...

October 28, 2020 at 10:26 am #7324405

martinH-16

Yes as I did some tests, the copy option on ct_other_template does not update, even if I add some text to the gutenberg editor.

October 28, 2020 at 3:18 pm #7326915

martinH-16

Okay so after trying to finish the website and finally sell it to customer, it still does not work. I added new button to the template, with new ACF field, add content to editor and resave, but nothing happend. I cannot see the new button in template and I can not translate the new acf field. Co problem is propably in copying the ct_other_template field.

October 29, 2020 at 8:04 am #7332049

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I see you already opened a new ticket for your new issue, and that is the correct way:
- https://wpml.org/forums/topic/my-templates-are-not-copied/

We limit 1 issue per 1 ticket, to keep things clear.

Can you please confirm you still have the same original issue:

But when you then afterwards set the ACF field or group translateable it never shows in translation editor, until you delete translated page

If so please follow Andres suggestion and try to replicate the issue on clean sandbox site provided:

- hidden link

Please let me know, kind regards,
Drazen

October 29, 2020 at 1:24 pm #7335887

martinH-16

Hello, is it possible to send you my site copy via Duplicator?

October 30, 2020 at 12:31 am #7339953

martinH-16

I cant replicate the problem. Can I send you duplicator package with my site? I have a thousands of custom fields there..

October 30, 2020 at 7:14 am #7341423

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Thanks for the feedback.

Sure, please follow the next steps:

- share Duplicator copy, but filter large files, like uploads folder, to keep the size of package smaller

- share administrator account for login

- share step by step guide on how can I check and see the issue.

More info: https://wpml.org/faq/provide-supporters-copy-site/

Thanks,
Drazen

November 2, 2020 at 7:45 am #7355189

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for sharing a duplicator copy, but I am stillnot sure what is the issue and how can I see it.

Please share step by step guide on how can I check the issue, what is the results and what is excepted result.

Thanks and kind regards,
Drazen

November 5, 2020 at 7:15 pm #7389027

martinH-16

Hello Dražen, Ok then,

1) Open Admin
2) Go to pages, find page HRR Catering
3) Open it in czech language - you can see the content.
4) Open translation editor - you can see translations.
5) Open frontend, change language from czech to other - english/german - > what you can see? Page without inner content.

hidden link - CZ, working
hidden link - DE, not working
hidden link - EN, not working

6) What I have found? The ct_other_template is not copied, when it is set up to Copy with WPML. It happens only on some pages.
7) Go to CZ version, click edit page, go to oxygen section, show all shortcodes, copy them
8) Go to EN or DE version, edit page, paste the shortcodes to the oxygen section.
9) save and open page on frontend - > it works, huh? (Yes, you copied the ct_other_template manually)
10) Open CZ version of page again, and open the translation of language, where you changed the shortcodes manually.
11) It opens classic WPML editor, without ACF fields, etc..

Ok, can you see the problem now?

November 6, 2020 at 8:10 am #7392141

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the feedback.

1) This doesn't sound like the issue that is this ticket intended to. This ticket was opened for your issues with ACF groups. (When you then afterwards set the ACF field or group translateable it never shows in translation editor, until you delete translated page)

2) I see you already have opened a ticket for your issue with templates, please continue there as we do not allow multiple tickets for the same issues. Only 1 issue per 1 ticket.

- https://wpml.org/forums/topic/my-templates-are-not-copied/

That being the case, I can only suggest those steps.

Please do not open new tickets for same issues and keep the ticket on topic with the original issue.

I suggest we close this one and you continue your work on that other ticket, I will update Andreas on your shared info in this ticket.

Thanks and kind regards,
Drazen