This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
October 23, 2018 at 10:12 am #2841779

Nazir

hi i have buy the plugin 79$ and have translate all plugin in WPML and when i do to se page and change lamguage to cinese there can see the words see here
hidden link

October 23, 2018 at 7:09 pm #2843932

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Have you translated the pages and products to your secondary languages? Also, how did you add the currency switcher? Are you using a widget, custom code, etc?

Please make sure your website meets the minimum requirements found here: https://wpml.org/home/minimum-requirements/

Lastly, To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

October 24, 2018 at 6:24 am #2845034

Nazir

i need paste currency in header and one widjet for mobile phone, i have no paste any code because i dont know, before i buy i have ask your support to give me the instruction she say she will search but have no answer again. i have translate in WPML> Translate plugin and theme from there. And please help me fast my chinese vendor are still waiting.

October 24, 2018 at 9:23 am #2845584

Nazir

now i have add on widjet but 1) have no flag 2) on widjet open can not do down see here
go to jumunona.com in left top widjet see at down if you wanna choose currency that can not go down

October 24, 2018 at 2:26 pm #2846804

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 24, 2018 at 2:55 pm #2846942

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Unfortunately I'm not able to access your site anylong. I am seeing an error now. While I was able to access your site, I could see that the language switcher does drop down. Please see attached screenshot.

If the switcher is not working when you try change currency, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

October 24, 2018 at 3:06 pm #2846998

Nazir

nooo problem is not i have no currency,
1) currency in Phone top left i need like language under the menu and when you press it it will be dropdown and you can choose, now currency in widjet so when dropdown you can not choose the second language do you understand? just go jumunona.com with mobile phone and see language dropdown and currency dropdown you will be uderstand.
2) The best is let the currency paste under the menu like language on computer version home page after the dashboard.
3)A lot of place still in english when i cange language to chinese but all plugin i already have translated. Maybe not when you go the admin panel and tell me what i need do more.
4)When i downloaded WPML plugin on my Hosting have start have problem and have HTTP ERROR 500 on page i dont know why have this and from where this come. You are professional please see and if you can fix or tell me what i do wrong.
5)When i download WPML plugin i speed will 22-30 second whyyyyy?? its very very big problem for me, because before is 6-8sec. Now my chinese vendor need add product so i need give them fast site PLEASE SEE FROM WHERE PROBLEM IS COME.
6)IMPORTAND for first please check me create account page and dokan dashboard page for chinese language because they importand for add product vendor just use dashboard for first so when dashboard page done 100% they will start add product.

October 24, 2018 at 3:09 pm #2847017

Nazir

and yes and have small quethions how i can change text under the page there have link for 4 page on russian so i need chane them too to chinese and english

October 24, 2018 at 5:15 pm #2847367

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

1. It is not possible to add the currency switcher using WooCommerce Multilingual options. You can try using the Shortcodes in Menus plugin.
- https://wordpress.org/plugins/shortcode-in-menus/

Then you can try adding one of these shortcodes:
you can use one of these:

[currency_switcher]
[currency_switcher switcher_style=list]
[currency_switcher switcher_style=list orientation=horizontal]
You can find more details here:
https://wpml.org/documentation/related-projects/woocommerce-multilingual/multi-currency-support-woocommerce/

If that does not work, you will likely need to contact your theme author or place the php code into the theme header.php file where you would like the switcher to display.

2. Same answer as above

3. Can you tell me a specific page where you translated to Chinese and the language switcher is not showing? I'm not able to load your site, so I am having a hard time checking this.

4. As this is a separate issue, please open a new ticket. It will be helpful if you can include any errors showing in your debug log in your new ticket. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

5. This sounds like it is the same issue as number 4 above.

6. I don't understand exactly what the issue is. However, if there is a problem with Dokan, please open a separate ticket as this is unrelated to the currency switcher issue and we allow one issue per ticket.

7. For the links in the footer, go to Appearance -> Widgets and make sure you have a menu selected in your main language. Then, go to Appearance -> Menus and make sure you have translated the menu.

Thanks!

October 26, 2018 at 10:49 am #2852821

Nazir

Hi the currency work its ok. my site when i chage language on dashboard be like this hidden link so can not see the page. You need go to my site from admin panel and see. And PLEASE give me your email im 2 days can not reply you because in China didnt work your site. I will text you in Email

October 26, 2018 at 3:55 pm #2853613

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I don't think this is an issue with WPML. When you open the browser console, I see an error showing related to caching.

To further test, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, does the page load after changing the language?

If you don't have a testing environment available and cannot test this on your live site, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to set up your site locally and run these tests for you.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply. I will also need the username and password of a user that was created before the duplicator package was created.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it. Thanks!

October 26, 2018 at 5:58 pm #2853943

Nazir

i downloaded that plugin but i dont understand what need to do there have this
Build aborted by server
The server cannot finish building due to installation limitations.
all is english i dont know what to do please text me on email i give you admin password and logib and see what the problem (jumunona@gmail.com)

October 26, 2018 at 9:27 pm #2854233

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Due to our support policy, I can only reply here on the forum.

I was able to complete the duplication package and set up a copy of your site locally. With your theme and only WPML plugins, WooCommerce and Visual Bakery activated, the language switcher works perfectly and displays the secondary pages.

I suggest you set up a staging site or make a full backup and then test this on your site. Then, activate the rest of the plugins one at a time to figure out which one is causing a conflict.

Please let me know your results.

October 27, 2018 at 12:29 am #2854292

Nazir

I suggest you set up a staging site or make a full backup and then test this on your site.

i dont understand what is mean

October 27, 2018 at 12:40 am #2854299

Nazir

can you just go my admin panel and do it by your self faster???