This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The logo of the 'Bridge' theme by Qode Interactive is not linking to the homepage of the second language, and instead, it is linking to the default language homepage. Solution: This should function normally like as it does with most of the WordPress themes. In this particular case, the user reports that there was some CSS directive that caused this problem.

This topic contains 8 replies, has 2 voices.

Last updated by morenan 2 years, 3 months ago.

Assigned support staff: Itamar.

Author Posts
April 14, 2017 at 6:53 pm #1254617

morenan

I am trying to: translate the logo in order to come on the italian page when i'm visiting the italian part and on the Uk page when i'm visiting the english website

xseries.nrcocchiali.com

I expected to see: to come on the italian page when i'm visiting the italian part and on the Uk page when i'm visiting the english website

Instead, I got: only the link on the english website

Steps to duplicate the issue: try to click on the logo please.
THANKS FOR YOUR SUPPORT 🙂

April 16, 2017 at 9:11 am #1254935

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello, @morenan.

Thank you for contacting the WPML support forum.

You are using the 'Bridge' theme by Qode Interactive which is compatible wit WPML https://wpml.org/theme/bridge/.
I can see the problem on your site.
Nevertheless, when I try this theme on my local server, I can not replicate this problem.
The logo links properly to its corresponding language.
Can you, please check if you have followed correctly the instructions on how to work with WPML and the Bridge theme?
You can find those documentations here https://wpml.org/2016/03/translate-bridge-theme-wpml/.

I look forward to your reply!

Thanks,
Itamar.

April 17, 2017 at 1:57 pm #1255306

morenan

I guess i've follwed everything carefully, otherwise the other translations would't work. I don't know where i can translate the logo in Italian (this is only one of several translations that i need...) I read carefully every posts on wpml related to The Bridge befor to decide to write to you, but this problem is going to blow my mind now: could oyu please tell me how to translate the logo in italian since there isn't an Option available for The Bridge in wpml? Thanks a lot
Ivano

April 18, 2017 at 7:42 am #1255711

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

I see, thanks for following all the instructions.
As I wrote up here when I test this on my local server, I have no problem with the link of the logo, and it is linking correctly to the homepage of the correct language (not the default language). This is being done automatically without the need to configure anything. But I'm testing it with a different version of this theme. Therefore, I think it would be best if I'll check things directly on your site.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.
For this, I'll need to install the Duplicator plugin on your site.
https://wordpress.org/plugins/duplicator/

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Thanks,
Itamar.

April 18, 2017 at 9:04 pm #1256492

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks Ivano for the access details.
I've installed your theme on my local server to test the issue. It looks like something is hardcoded into your theme because only upon installation I got the logo to point to your site. When I replaced it, it got corrected. Can you try, please to remove and then add back again the different logos on your site and save the changes? If you use a caching plugin or some caching method on your server, please also clear the cache after that you make those changes.
Thanks,
Itamar.

April 19, 2017 at 5:05 pm #1257365

morenan

Hi Itamar,
Thanks for your answer.. and i'm sorry for my late reply but i was out of office today. I've just tried, deleting the cache on my browser.. but unfortunately the problem is still there.
If you wanna to try to put a temporary logo on the live site, just to see what's happen by my side.. feel free to do that. I've just advised my client about some works on his website, so, for a short time he won't blame me of something will be not correctly displayed on the live website.
I'm sorry, but i can't nderstand how to figure it out and i need to because from friday, new translations will be done.. and the situation will become more complicated.. Sorry for that but i really need all your efforts if you can follow this situation. Thanks for understanding. 🙂
Ivano

April 20, 2017 at 10:33 am #1257891

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Ivano.

Cache issue
I didn't mean clearing the cache from your browser. I meant clearing it from your site or server if you use ant caching methods on it. Anyway, it doesn't look like a cache issue.

Update: WP Memory Limit
I've added this code to the wp-config.php of your site.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

It might not be related to the issue but is highly recommended to do so.
It has to do with the minimum requirements for WPML. You can read about it here.
https://wpml.org/home/minimum-requirements/

Logo - main issue
As I already wrote here, I think that something was changed in either the header.php or functions.php (or another file) of your theme and this is causing this problem.
I get to this conclusion because when I install the Bridge theme that I get from you site on a clean WordPress installation the logo (just the default logo not your logo) points to your site's homepage.
Please see attached screenshot xseries-link.jpg
Do you remember making any change in any of your theme files?
Maybe somebody else helped you when you were developing this site, and he/she might know?
If you do not know of any change, then I would like to ask you for a clean copy of the Bridge theme version 10.1.2 (not the one that you currently have on your site) to make some diff checks and try to locate the source of this issue.
Can you upload the zip file of the theme to a service like Google Drive or Dropbox where I can download it from?
For this, I'll enable the next reply as private, so you can share the link with me.

Thanks,
Itamar.

April 25, 2017 at 8:43 pm #1261709

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Ivano.
I'm glad that the initial problem is solved now 🙂

The logo at the header of your site (and also in many many other WordPress sites) links to the homepage of the site.
Your site mostly consists of a one-page template.
Therefore, it is all the homepage and there, so nothing is happening when you press the logo in the header.
If you want to reach the top of the page easily, you have the back-to-top arrow on the right bottom corner of your site.
Please see attached screenshot back-to-top.jpg
Clicking it will automatically scroll the view back to the top.
Nevertheless, the logo in the header is doing its job.
If for example, you go to another page on your site and click the logo in the header it directs you to your homepage.
Please try it on this link, for example.
hidden link
Am I right or did I misunderstand what you meant?

April 26, 2017 at 10:35 am #1262120

morenan

Itamar
Again you were Superb and very patient!!! Thank you to have solved my problem and i wish you all the best.
Have a very Good Day 🙂
Good Boy!!!
Ivano