This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 2 voices.

Last updated by Andreas W. 8 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
December 12, 2018 at 12:06 pm #2993229

marinaH

Tell us what you are trying to do? I'm translating manually from ENG to NL "home" page.

Is there any documentation that you are following? I follow your recommendation support before: Sometimes this can happen if the theme's config file is not loading correctly.

-Go to Plugins -> Add new -> Commercial -> and click on "check for updates"
-Edit the translation and finish it as it is
-Make a small change in the original page
-Edit the translation again
But its not working.

Is there a similar example that we can see?

What is the link to your site? hidden link
See 1st image of translation and 2nd of Home page, the text do not much. Thanks!

December 12, 2018 at 3:46 pm #2994219

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

From your screenshot I see you are trying to translate a custom field of Yoast SEO by using the WPML Translation Editor. Please take note that translations for posts and pages with this method need to be completed 100% to be able to see them on the frontend.

Could you first of all go to WPML -> Settings -> Custom Field Translation and check if the respective field is enabled for translation?

Next to translate strings based on Yoast SEO you will need to go to WPML -> String Translation. You are able to search for literal strings inside the search field or you might select the domain admin_texts_wpseo_titles and look for the string name. (Example: [wpseo_titles]metadesc-post).

A more detailed information about using Yoast SEO in combination with WPML you canfind here:

https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

Please let me know if this solved your issue.

Best regards,
Andreas

December 13, 2018 at 5:25 pm #2998919

marinaH

Dear Andreas, I have done all the changes as you mentioned above. Still need help for "Home" page still the same problem.

December 13, 2018 at 6:50 pm #2999126

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Before we take further steps could you please proceed with following configuration.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.

Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Another issue regarding your debug information is that you are using an outdated version of PHP. Please make sure to update your PHP to the latest version.

You can download it here:

hidden link

Also please make sure that your Theme and any plugin used on the site is updated to the latest version.

Please let me know if this solved your issue. Otherwise, I will be able to offer you to have a look at your admin panel to investigate the problem further.

Best regards,
Andreas

December 21, 2018 at 1:14 pm #3024898

marinaH

Dear Andreas, I did all updates as you recommend thanks! But the home page is still the same wrong texts. Please help me.

December 21, 2018 at 2:05 pm #3025006

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Best regards
Andreas

December 21, 2018 at 6:51 pm #3026059

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I took a look at your site and I had a couple questions. The content of each site was created with Beaver Builder?

Could you please give me some more detailed information with detailed steps about how the website was built?

Further, I tried to create a backup package of your site with Duplicator but due to server restrictions of your hosting provider I was not able to create a complete package.

In order to save time on troubleshooting this issue I created a test site and I would kindly like to ask you to migrate your site there for further investigation.

To troubleshoot this issue without affecting your site I created a test server for you in Cloudways (https://wpml.org/hosting-partner/cloudways/).

If it is OK with you, we can migrate your content there to further debugging without any risk on your end.

To do the migration please follow these simple steps:
-Install this plugin in your site: Cloudways WordPress Migrator (https://wordpress.org/plugins/bv-cloudways-automated-migration/)
-After you activate it you will be redirected to the migration form
-Fill it with this information:
--Email
Your email here, as you will be notified about the migration progress.

--Database Name
znpfmxbuzr

--Database Username
znpfmxbuzr

--Database Password
tsPU4bpB2Q

--SFTP Username
andreas-2993229

--Destination Site URL
hidden link

--Server Public IP Address
142.93.143.140

--SFTP Password
andreas-2993229

-Agree with the terms of service and click on "Migrate"

More information:
hidden link

You will get an email when the migration starts, and one when the migration ends.

Let me know when the migration is ready and I will check the issue in the test site immediately.

Kind regards
Andreas

The copy of your site will be online, but search engines won't index it (the copy) so you don't have to worry about duplicate content.

The information you share with us will be confidential. Once the problem is resolved the details you shared with us will be deleted from our records.
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

December 21, 2018 at 6:53 pm #3026062

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

You should have received a private message with credentials for a test server. I am sending you this message as notification.

Please let me know if you got any questions.

Kind regards
Andreas

December 22, 2018 at 1:49 pm #3027543

marinaH

Hi Andreas, the migration completed successfully. Answer to our question:
The content of each site was created with Beaver Builder? Yes

Could you please give me some more detailed information with detailed steps about how the website was built? It was my first WP website, it was builed directly to Travel extend Pro version, it was a problem with changing to real domain name from live site to a new WP, Godaddy support did it for me. Don't know what else, ask me questions.

December 26, 2018 at 7:29 pm #3034934

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I took a look at your website and sadly I can not follow the way this site was build. When I check for your front-page I can find on the translation editor content that is not part of your actual front-page. (See screenshots)

When changing to a default theme like Twenty Seventeen or the Cherry Theme all the content appears in proper manner.

It appears that we are dealing here possibly with a theme compatibility issue. Please take look at the following link to find a list with themes that approved as WPML ready by the theme authors or have been tested by our compatibility team.

https://wpml.org/documentation/theme-compatibility/?wpv_view_count=112654&dev%5B%5D=0&wpv-theme-category=0&wpv_post_search=Travel&wpv_filter_submit=Search

We would kindly like to ask you to reach out to the theme authors and to invite them to join our Go-Global Program to help us make WordPress multilingual.

https://wpml.org/documentation/theme-compatibility/go-global-program/

Best regards,
Andreas

December 27, 2018 at 2:52 pm #3037313

marinaH

Hi Andreas, Thanks for a good support! From the screenshots I see that the texts are from first look of the website about a couple month ago, now I have updated it. Anyway, I sent an email to the web theme authors and asked for help. As soon I get a reply will update you. Kind regards, Marina

December 27, 2018 at 7:21 pm #3038315

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you very much for the notification.

It would be very helpful to get some feedback from the BeaverBuilder authors as I tried to duplicate your homepage to modify it a little, as this sometimes might solve such issues.

In this case the content was reversed to its old state right after duplicating the page. Same result came up when changing top a default theme. Further, Beaver Builder is asking for an upgrade as it seems you are using a lite version of the plugin.

Please get back to us as soon you got an update and we will be glad to assist you.

Best regards
Andreas

December 28, 2018 at 3:12 pm #3040581

marinaH

Hi, here you have the support from D5 creation, so they don't want to help me with WPML.
"Dear Sir/Madam,

Greetings from D5 Creation!

Please consider that a Theme may not be compatible with all Third Party Products and we also mentioned it in our Terms of Services. WPML is a Paid Premium Product and is not Listed at WordPress.org. All of our Themes are WordPress.org listed and must have a Free Version. We can check with the Plugins which are listed at WordPress.org. Unfortunately, we could not check our Themes with WPML as it is a Paid Product. We recommend the Plugin qTranslate X and/or Google Language Translator for Multilingual Sites. Those are FREE! Google Language Translator is very simple and you do not need anything with your different texts. It will show the site in any Language translating the texts automatically. We have also used the Plugin for our site D5 Creation. You can find Our Tutorial Here."
Then I have upgrated Beaver builder to Beaver Builder Plugin (Standard Version)
Please let me know if I can use WPML or I have to use qTranslate X, I really like to use WPML.
Thanks! Regards, Marina

December 28, 2018 at 6:10 pm #3040989

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

Beaver Builder is compatible with WPML and has been tested by our compatibility team.

https://wpml.org/documentation/plugins-compatibility/?wpv_view_count=119945&dev=0&wpv-plugin-functionality=0&wpv_post_search=beaver&wpv_filter_submit=Search

Indeed, I checked your website again and I realized that most translations are working as expected. Please also take not again that a translation has be completed to 100% the first time it was edited to show up on the frontend.

The only exception here is your frontpage, which shows a different content on the translation editor than on frontend. I further tried to edit your Beaver Builder frontend design but for some reason it does not respond. Otherwise when I try to edit the page "Altea" with Beaver Builder everything works as supposed to and the page is translatable with WPML.

I would like to reach out to the Beaver Builder Support again and explain that your frontpage design is not responding. This is not a WPML issue as the issue persists when WPML is disabled.

Possibly a workaround would be to set up a new page, translate it and then use it as your frontpage.

Please let me know if you need any further assistance.

Kind regards
Andreas

December 30, 2018 at 11:56 am #3043092

marinaH

Hi, Thanks for helping out! Unfortunatly I don't know how to do "Possibly a workaround would be to set up a new page, translate it and then use it as your frontpage." I will see if the qTranslate X plugin will work without any problems, then I would not use WPML on this website. But I have another website to build, so hope I will use WPML on other web. Don't want to close this ticket support yet. Kind regards, Marina