This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Alejandro 4 months, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
April 2, 2019 at 11:45 am #3516719

hooiC

I am trying to:hidden languages not appearing on the front of LIVE website. in the user profile, I have enabled display of languages on website under my user profile. this has worked in the development site but not on the production(live) site.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

April 3, 2019 at 7:27 am #3523057

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

I suppose you mean that you cannot see the hidden languages while logged in on your profile, even though you selected the "Show Hidden language option"?

If that's the case then, make sure to flush all your cache and check if in WPML > Support, on the parameter "Memory Used" the value is much lower than 256M (below 180M, for example)

If that doesn't help, could you create a temporary user for me so i can take a closer look at the issue? i will not make any modifications on the front-end and probably small to no modifications on the back-end as well (and if i do, i'll let you know exactly what i did and of course will undo it if necessary)

Regards.

April 3, 2019 at 11:55 am #3525747

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I checked the site and noted something.
It seems like on the front-end we are treated as logged-out users, i can't see the admin bar or anything.

I see that you changed the login URL, did you add a code for that? if you did, could you tell me where so i can see it (or paste it here if i can't access where you added it).

Let me know.

April 3, 2019 at 12:56 pm #3526301

hooiC

Hi Alejandro, the info in WordPress access details is correct. I am not sure what you mean by code. ignore the info in ftp.

April 3, 2019 at 12:57 pm #3526307

hooiC

Hi, are you able to get into the admin site?

April 3, 2019 at 1:28 pm #3526561

hooiC

Hi Alejandro i can see what you mean, when you type in the url i gave you , you were redirected to another url? maybe that is the reason why I can see the hidden site...you should be able to access the WP admin with the credential details I sent you.

April 3, 2019 at 1:28 pm #3526563

hooiC

Hi Alejandro i can see what you mean, when you type in the url i gave you , you were redirected to another url? maybe that is the reason why I can see the hidden site...you should be able to access the WP admin with the credential details I sent you. i have asked my it guy abotu the redirection

April 3, 2019 at 2:18 pm #3527019

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

just to be clear (because i don't really know if i explained myself clearly enough) i did manage to access your site.

I believe the problem is that the system doesn't recognizes us as logged in and that's why the languages do not appear.

I found something interesting as well and maybe it's part of the problem: https://wpml.org/errata/single-sign-on-feature-not-working-due-to-setting-the-x-frame-options-to-sameorigin/

I did some digging and found out that your site is hosted on AWS and it should automatically set X-Frame_Options to SAMEORIGIN, so can you ask your hosting support or your "server guy" to check and remove that option and see if that works as well?

The most important part here is to be able to see the admin bar on the site when logged-in just so we can make sure the system is recognizing us as logged in users.

Let me know how it goes.

April 3, 2019 at 3:49 pm #3528359

hooiC

Hi Alejandro, this is what our IT consultant has said:
"The SAMEORIGIN is a feature of wordpress – has been since v3.
Both webdev and live set the same headers.
Not sure it is the reason for the hidden sites not displaying"
its working on the dev site.
I have changed your credential details as the IT consultant planning to activate the W3TC plugin shortly. if you need it , please let me know . i will send once I know we all can get back in.

April 4, 2019 at 6:40 am #3532355

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

X-Frame_Options are not a WordPress option although it uses it, as far as i know it's a server-side option (documentation: https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/X-Frame-Options )

I suggest you try to spot differences on the server-side from both sides.

In the meantime, can i have credentials for the dev site once the live site is accessible as well? i can try to spot differences on the installation, for example, that way we can try to isolate the problem.

April 8, 2019 at 3:34 pm #3559809

hooiC

Hi Alejandro, seeing we have an issue with hiding the sites, I decided to UNHIDE French site on the live site for a short moment. I noticed on the front end of the website, i can only click on the French site if I first click on Irish on the language switcher! how do i fix this issue?

April 8, 2019 at 4:02 pm #3559977

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Is there a post or a place where i can test this? are we still talking about the production site?

Let me know where can i test this so i can go and check what's going on.

In the meantime, please follow the instructions mentioned on this page: https://wpml.org/documentation/support/debugging-wpml/

Try to recreate the problem once you have added those lines to your wp-config.php file and then go to your installation's wp-content folder and find the "debug.log" file that should've appeared by now (it will appear if it enocunters an error in your server).

Then, upload that file into a storage platform of your choosing (Google Drive, Dropbox, etc) and send me the link (make sure it's set as "public" otherwise i won't be able to access its content) so i can download it and take a look at it, and determine where to go from there.

April 9, 2019 at 8:11 am #3563979

hooiC

Hi Alejandro, are you able to get into our production site? we will be sending you the debug.log shortly.

April 9, 2019 at 8:14 am #3564035

hooiC

here's the debug.log. not sure what this means? why its referring to the plugin..
Logs as discussed:
[09-Apr-2019 07:20:52 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:21:04 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:21:05 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:21:11 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:23:08 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:48:50 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:49:09 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:49:31 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:50:51 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:51:09 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:52:21 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:52:28 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:54:55 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:56:51 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:57:07 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:57:29 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 07:59:24 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:00:07 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:03:08 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:03:14 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:03:16 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:03:39 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:04:09 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:05:17 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:06:00 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:06:55 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:07:36 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:07:43 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46
[09-Apr-2019 08:08:20 UTC] PHP Notice: Undefined index: woocommerce_items_in_cart in /var/www/html/wp-content/plugins/woocommerce-multilingual/classes/urls/class-wcml-xdomain-data.php on line 46

April 9, 2019 at 11:16 am #3565945

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, so first of all, i couldn't access the live site with the last credentials. so please re-add them again.

About the log. that is a cookie warning, but it's not an error, so it's harmless for now and that's good.

It seems to trigger when you

- add a product
- remove a product
- change language

And it's related to the settings in WooCommerce mulitlingual and the different domains. the system seems to have a hard time communicating with each domain.

Does this happen on the dev server as well? because if it doesn't, then the problem is most likely a server configuration issue.

Let me know please.

The topic ‘[Closed] hidden languages not appearing on the front of website’ is closed to new replies.