This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 2 voices.

Last updated by Bigul 2 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 23, 2019 at 4:28 pm #4268109

ahmedA-75

My website is hidden link

The autoload is high. How can I decrease this?

The top 2 options are both WPML related.

1. wpml_translation_services = 183801
2. _wpml_batch_report = 180927

I keep getting cloudflare errors especially in the backend because of this.

July 24, 2019 at 6:14 am #4270513

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please share with me the following details to track the issue.

a) To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

b) Which tool/plugin you are using for analyzing the auto load performance

c) Which type of hosting plan you are using now, Shared or VPS or Dedicated?

--
Thanks!

Bigul

July 24, 2019 at 8:41 am #4271583

ahmedA-75

a) I provided this.

b) The support at the host provided this info. They performed an SQL query to get this.

c) The website is hosted on wp engine. I'm not sure about the plan.

July 24, 2019 at 5:37 pm #4276681

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

July 25, 2019 at 1:30 pm #4283577

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. Please note, I am getting timeout error few times while visiting the Dashboard pages. Have you had it before?

Please try the following steps after site backup and check is there any difference in the performance.

1) Go to WPML>>Languages>>Make themes work multilingual
2) Enable *Adjust IDs for multilingual functionality* option
3) Go to WPML>>String Translation, scroll to *Auto register strings for translation* section
4) Click on *Edit* button
5) Choose all string domains and click on Apply button

Please check the attached image for more details and let me know your feedback.

--
Thanks!

Bigul

July 25, 2019 at 2:47 pm #4284393

ahmedA-75

I tried this and the backend became even slower!
The dashboard is the worst. Go to the themes page first and then jump to any other page.
Deactivating the plugin really makes the backend works faster, so it has to be the plugin settings maybe.

July 25, 2019 at 4:30 pm #4285173

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please deactivate WPML String Translation plugin for moment for testing and check is there any difference in the site performance.

Also please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

July 25, 2019 at 5:07 pm #4285331

ahmedA-75

Hi,

1. Deactivating the plugin didn't help at all.

2. I tried to add the debug lines, however, the line: define(‘WP_DEBUG’, false); didn't exist. I added the lines anyway but it didn't generate a debug.log file. It might be blocked by the host wp engine?

Anyway, I accessed the admin are of the host and found the below error logs.
https://pastebin.com/f2acS6dn

Thanks.

July 25, 2019 at 6:31 pm #4285587

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The Debug log is showing few database warnings related to WPML.

For your kind information, our developers are currently working on the performance improvements and we are expecting to release a beta version soon. So is it possible for you to create a staging site(clone of live site) on the same hosting environment to test the performance issues.

I have more request. If possible, please activate Page load time Google extension - hidden link and try the following steps. This information will help us to track the issue.

a) What is the speed when only WPML is enabled (without any addons, like WPML String Translation plugin for example)

b) What is the speed when all WPML plugins are disabled

c) What is the speed when WPML Translation Management plugin is disabled and any other WPML plugins have installed

d) What is the speed when WPML String Translation plugin is disabled and any other WPML plugins have installed

--
Thanks!

Bigul

July 27, 2019 at 2:29 pm #4293643

ahmedA-75

It is definitely faster now with WPML Translation Management and WPML String Translation plugins disabled.

July 28, 2019 at 8:33 am #4295179

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. It requires further debugging. Therefore is it possible for you to create a staging site(clone of live site) on the same hosting environment to test the performance issues. Because it will help us do the testing without affecting your live site.

--
Thanks!

Bigul

July 28, 2019 at 10:40 am #4295397

ahmedA-75

I can't create a staging site at the moment as it's a huge site and the last time I did it, it ate up all the server's space.

July 29, 2019 at 7:44 am #4297419

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

The topic ‘[Closed] High autload – WPML options are top 2’ is closed to new replies.