This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Rohan Sadanandan 1 month, 3 weeks ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
August 13, 2019 at 6:16 am #4385171

shefaliP

Hello,

I have URL formate like this: hidden link

However, I need the entire URL in English formate.

August 13, 2019 at 12:29 pm #4388035

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

If you want to change the slug of a translated page, go to Pages > Click on the Edit button below the page & switch the language on top of the admin menu. Then just click on the title of the page & you will be able to view & edit the permalink of the page.

You can read more about this here:
https://wpml.org/documentation/getting-started-guide/translating-page-slugs/

If you have any doubts, please let me know.

Thanks,
Rohan

August 14, 2019 at 12:45 pm #4394891

shefaliP

Hi,
I could not locate this - > https://wpml.org/wp-content/uploads/2013/01/custom-post-type-translation-link.png

We are not using types plugin.
We could not locate - > https://wpml.org/wp-content/uploads/2013/01/making-custom-post-type-translatable.png

Can you help?

August 14, 2019 at 1:10 pm #4395019

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For translating custom post types, navigate to WPML > Settings > Post Types Translation & select the Custom Post you need to translate and set it to translatable.

If you have any doubts, please let me know.

Thanks,
Rohan

August 16, 2019 at 4:40 am #4404671

shefaliP

I don't have any custom post type just issue with the slug of the main post, we have two languages, Hindi and English, but here Hindi post generates URL in Hindi which we need in English.

August 16, 2019 at 11:46 am #4406139

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

By default, the post slug is generated automatically based on the title.
If you want to change this setting, you can navigate to WPML > Settings > Translated documents options > Page URL and select Translate & click on save(See attached screenshot)

If you have any doubts, please let me know.

Also, I request you to update the WP Memory limit to at least 128MB which is the minimum requirement for WPML: https://wpml.org/home/minimum-requirements/

Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy publishing. */

Thanks,
Rohan

August 17, 2019 at 5:10 am #4409409

shefaliP

I don't see this option:
hidden link

username : flora

Password : FF_September30_T

August 19, 2019 at 9:22 am #4414847

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

It seems that you have not installed the "WPML Translation Management" add-on plugin.
Could you please install the same?

Thanks,
Rohan