This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Home are different pages in the two languages after move to new hosting Solution: the problems is that the client name record for the add-on domain is still pointing to the old WordPress installation Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by Muriel 2 years, 8 months ago.

Assigned support staff: Yvette.

Author Posts
December 21, 2016 at 9:09 am #1165408

Muriel

I am trying to: Look at the homepage in English

URL of (my) website where problem appears: hidden link

I expected to see: The same homepage as hidden link but in English.

Instead, I got: The old homepage that we had before.

Steps to duplicate the issue: Go to the website and look at the homepage 😀

We have moved the complete website to a new hosting, as the old one did not want to upgrade their PHP-version.
We have set a new page as homepage, the translation does exist and can be openend via hidden link or hidden link
The page that is shown on the English site is the old home page.
Funny thing is, I have renamed the English version to moodboard-home and then you get a 404 error? When you go to hidden link

I have doublechecked the permalinks, the settings for the homepage, cleared the local browser cache but nothing.
Tried opening in a new browser in which the website was never opened, nothing.

Please help!

December 21, 2016 at 1:18 pm #1165692

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello.

I will be helping you with this issue. I would like to check the icl_translations table entries to see what post-id is linked to the new homepage.

Temporary access to your system
Could you please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem? The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

Thanks in advance for your collaboration.

December 21, 2016 at 7:24 pm #1166034

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello.

I believe the problems is that your cname record for the add-on domain is still pointing to the old WordPress installation. Here is what I did so you can see this.

1. I temporarily changed the URL format to use the languages by parameter option.
2. I then checked the domain URLs and you can see that with this new URL format, the landing pages are as you expect to see them
3. I then chose a page "About" in English and made a slight modification (e.g. added elipses at end of the first text module). (see image)
4. I can see that in the current english domain version of this page does not show this recent edit. This shows that the English domain is still pointing to the old WordPress installation.

I have left the URL format configured as language-by-parameter so you can see this more clearly. In order to correct this you need to update the cname records to point to the new server/installation.

I wait for your comments.

December 22, 2016 at 9:22 am #1166399

Muriel

I have updated the CNAME record, but can't seem to get the "other domain per language" working?

When I choose language with parameter it works fine?

December 22, 2016 at 1:45 pm #1166731

Muriel

The issue is solved! The domain is set as an alias and everything works! 🙂
Thank you en enjoy the holidays!

December 22, 2016 at 1:54 pm #1166739

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there.

This seems to be working fine for me (see image). Is there still a problem?

December 22, 2016 at 1:58 pm #1166743

Muriel

Hi Yvette check my post above yours. 😉