Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year, 7 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 22, 2020 at 11:42 am #5967857

gentianG

After installing wpml the home site hidden link when i press the language switcher for the english version to go to logic.al/en/ redirects to a random page. How do I fix this?

April 22, 2020 at 5:31 pm #5971069

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

First of all, thank you very much for your patience and sorry to have you waiting - there is a very full ticket queue at the moment and it takes us a bit more than usual to answer tickets.

Now, regarding your request, that sounds to me like it might be caused by one of the active plugins.

Can you please try this:

1. Create a full backup of the site
2. Disable all the non-WPML plugins and see if the issue is still happening (if it doesn't, please try to enable each plugin back and check when the issue is happening so that you can find the plugin that creates that issue)
3. If it still doesn't work, please switch from the current theme to a WordPress default theme (like twentysixteen)
4. See if the issue is still happening
5. If it's still happening, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 23, 2020 at 10:43 am #5975985

gentianG

At the language url format if I change to language added as parameter, the English version appears. But I need to use the format with logic.al/en/

April 23, 2020 at 3:25 pm #5978667

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there.

The issue comes from a redirection that is set inside YOAST (SEO > Redirects) - I'm attaching a screenshot below.

If you remove that from the list, things should get back to normal.

Kind regards,
Mihai

Screenshot 2020-04-23 at 18.23.43.png