This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 3 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 9, 2019 at 4:59 pm #4173329

arthurG-7

I am trying to: translate home page

Link to a page where the issue can be seen: hidden link

I expected to see: translation

Instead, I got: only the main language version, although all the strings are translated. Additionnaly, I only see the "+" and not de pencil button. When I click on the "+", the strings translated are displayed. It works for all pages but the home page.

July 9, 2019 at 7:34 pm #4174083

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 10, 2019 at 7:09 pm #4184003

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and confirmed the issue. Please, try the following:

1 - Make sure your server environment meets our minimum requirements as described at: https://wpml.org/home/minimum-requirements/. For example, currently you have just 40MB as the maximum memory limit reserved for WordPress, the minimum to run WPML is 128MB I recommend to increase it to 256MB (see: https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php). You can see your current values in your WordPress Dashboard > WPML > Support settings.

2 - Make sure all your WPML related plugins are updated to their latest versions from your WordPress Dashboard > Plugins settings.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

3 - If the above doesn't help to fix your issue, then I recommend you to make a duplication of your current page and manually edit the content for your secondary language. You can read all the details of this approach at: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please, let me know if helps. Have a nice day.

July 11, 2019 at 8:05 am #4187187

arthurG-7

1 - Done
2 - Done

This is still not working. Point 3 is not a solution for me, this is the reason I bought the plugin. Otherwise, it is useless to have spent money on your plugin, I could have done that directly.

Can you investigate why it is not working and let me know what to do to fix this?

Arthur

July 11, 2019 at 5:05 pm #4192167

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Arthur,

Thank you for the updates, I do understand your points. Let's proceed with a more detailed investigation,may I ask you to provide us with some FTP access details as well? The reason I am asking that is to turn on the WP_DEBUG mode and watch your log files in order for some indication of what's happening in your particular case, also it helps me to restore access to your WordPress Dashboard, force plugin deactivation and so on. I will enable a private reply so you can safely send these FTP details. Thank you for your collaboration and continued patience, have a nice day.

The topic ‘[Closed] Home page does not show translation’ is closed to new replies.