Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bigul 8 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
March 12, 2019 at 12:21 pm

shahzadA

I am trying to: Make the Home page all in English, as well as show the language switcher

Link to a page where the issue can be seen:

I expected to see: hidden link (all posts in English)

Instead, I got: hidden link (mixed content in different languages)

Hello there,

I'm trying to integrate Buddypress to my website. To integrate it, I got the message that Language URL format must be "Different Languages in Directories"
I chose it and I had the option either to choose html file or Edit root page.
I Chose root page creation. Copied the code in it and the page appeared at: hidden link

But the issue is this new page is showing mixed content as well as no language switcher. BTW I did not hide language switcher on the options page and did not check that box.

Lastly Buddypress
Register hidden link and
Activate hidden link" pages are giving 404 errors.

Can you please help me with that?

March 13, 2019 at 8:26 am #3330627

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

The root page(hidden link) will not have languages. So there are limitations to list all language posts there. Please check the attached images for more details.

So please share more about your requirement(for homepage) for tracking the issue.

The Register and Activate pages listing fine for the non-login users. Please check.

--
Thanks!

Bigul

March 13, 2019 at 10:42 am #3332145

shahzadA

Hi there,

Thank you for your reply and for sorting out the Register and Activate pages.

My requirements for Home Page are very simple:

1. All posts should be in English

2. Language switcher should show in the menu (as in other pages) so that people may choose their language of choice.

I think these are the fundamental requirements for any multilingual website.

Please tell me how to incorporate these 2 simple points in my website's home page?

Regards.

March 13, 2019 at 3:03 pm #3335321

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. The homepage of the site is hidden link and it is working as expected for me. It is happening because you have selected *Use directory for default language*. Please check the attached images.

Would you like to display language switcher and English posts in the root page hidden link like hidden link? Please let me know your feedback.

--
Thanks!

Bigul

March 14, 2019 at 5:11 am #3340571

shahzadA

Hello there,

I'm all confused now. Isn't root page suppose to be the Home Page? When someone types the URL: hidden link
he lands on the root page. Which is I think the Home page as well, or is it not?

And if he lands on the root page how can he go to the respective language's Home page if there's no language switcher?

Of course I want to display language switcher and English posts in the root page hidden link like hidden link

Please help me out.

March 14, 2019 at 4:02 pm #3346779

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

March 14, 2019 at 4:53 pm #3347249

shahzadA

Hi there,

Of course please install the plugin and make the necessary changes.

But please do it at your earliest convenience as the website is looking ugly and there's no way for visitors to browse respective language page.

March 15, 2019 at 6:45 am #3351539

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of your site and debugging the issue now. Will get back to you soon. Please wait.

--
Thanks!

Bigul

March 15, 2019 at 2:10 pm #3354477

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the English posts are showing on Root page in my local copy after I set the filter for it in tagDiv element settings. Please check the attached images.

All languages posts are showing in Root page because the Root page does not have a language since it's the site's root page - https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#what-is-a-root-page-and-do-i-need-one. The same rule is applicable for the language switcher also and it will not display in Root page. I have tried the followings custom language switcher options in my local copy but the result is the same.

[wpml_language_switcher type="custom" flags=1 native=1 translated=0][/wpml_language_switcher]

do_action( 'wpml_add_language_selector' );

Therefore as a workaround, you can add custom language switcher via HTML code on Root page.

Or we can redirect the user to the English Homepage. For example, when we are visiting hidden link will redirect to hidden link. Please try the following steps after a full site backup and let me know your feedback.

1) Create a new PHP file *root-page.php* and place it in *Root folder* of the site
2) Add the following code in *root-page.php* file and save the changes

<?php

wp_redirect( home_url() );
exit;

3) Visit WPML>>Languages>>Language URL format
4) Choose *Use directory for default language* option
5) Choose *HTML file* option
6) Add *root-page.php* as the value for *HTML file* field
7) Save the settings

Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#selecting-an-html-file

--
Thanks!

Bigul

March 16, 2019 at 7:33 am #3359147

shahzadA

Hi Bigul,

Thank you very much for your support. My issue is resolved and the home page is correctly showing.

The code you specified: <?php

wp_redirect( home_url() );
exit;

didn't work for some reason, instead I used this code for root-page.php:
<?php

header('Location: hidden link');
exit();

Thanks and regards.

March 16, 2019 at 9:33 am #3359491

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Happy to know the issue is resolved now. Please feel free to open new ticket if you need any assistance.

--
Thanks!

Bigul