This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Riffaz 6 months ago.

Assigned support staff: Riffaz.

Author Posts
April 6, 2019 at 3:21 pm #3549359
yasinH-2

Tell us what you are trying to do?

1- Why does my home page have no language switcher even though most of it is translated?

2- When I am on the Translated Arabic shop page, the widget filters doesnt show, even though I translated it, why? and how to make it show please?

For example:

English Shop Page:
hidden link

hidden link

Arabic Shop Page:
hidden link

hidden link

What is the link to your site?
savemnt.com

April 7, 2019 at 7:39 am #3550931

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

1)
As long as the translation for the homepage exists then you should be able to switch the language using the language switcher.

Are you using GoDaddy for a host ?

Can you please go to your database and check your wp_options table to make sure both HomeURL and SiteURL are both filled in correctly.

Let me know how it goes.

2)
Please ask your every new question in a new ticket to avoid the confusion.
I split this for you.
Please follow: https://wpml.org/forums/topic/the-widget-filters-doesnt-show-in-second-language-shop-even-though-i-translated-it-why/

Regards,
Riffaz.

April 7, 2019 at 5:06 pm #3552635

yasinH-2

I will check,

However when I write this link, it should lead me to the arabic page "hidden link"

instead it redirects me to "hidden link"

that is not a correct behavior, right?

April 7, 2019 at 5:39 pm #3552737

yasinH-2

I want the main page to load hidden link

April 9, 2019 at 12:44 am #3561883

yasinH-2

TMDHOSTING reply:

Sorry I sent this to the other ticket by mistake.

April 9, 2019 at 1:29 pm #3567319

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I just noticed you are using Cloudflare, redux and some script inserting plugins.

Could you please disable all the plugins except WPML ? then check the issue?

Let me know how it goes.

Regards,

April 10, 2019 at 5:25 pm #3579391

yasinH-2

I tried deactivating all plugins but still no Arabic Home page....Please feel free to access my website using the login details I just shared in the widget ticket as I am out of solutions.

April 14, 2019 at 9:52 am #3607335

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Now it works fine: hidden link

It seems DOKAN plugin has some issue or conflict with in your site: hidden link
It happens in both English and Arabic site. All these come from DOKAN
I suggest you to contact DOKAN support and ask about this first before proceding anything else.

Regards,

April 14, 2019 at 4:37 pm #3608393

yasinH-2

Dear Team,

Thank you for the home page language switcher but I noticed that you apparently changed the permalink structure and the Vendor Dashboard Buttons like "Products button" doesn't lead anywhere now.

hidden link

all of the buttons here on the Vendor Dashboard aren't working anymore.

April 15, 2019 at 1:10 pm #3613613

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the inconvenience.

It seems like the the issue was with vendor plugin.

Please change your permalinks as your old links.

Can I give you instruction to move your site to a test server and we can continue from there?
So that won't effect your site in any way.

Regards,

April 15, 2019 at 1:18 pm #3613691

yasinH-2

Can you please help me fix the permalinks as your side changed it please and am not sure I can fix it on my own?

also I do have a test server: Savemnt.com/dev

Username: savemntc
Password: e7f#Ce.S68dP3M
Control Panel URL: hidden link

From the file manager:

Public_html/dev/

April 15, 2019 at 1:26 pm #3613741

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I did not change any permalink.
I just deactivated the plugins.
So that could have made these changes.

You said here : https://wpml.org/forums/topic/home-page-language-switcher-2/#post-3579391 you already tried deactivating plugins but it seems you did not deactivate ALL the plugins.

You can just migrate your site to our test server.
You do not have to create it.

but before that please fix the permalink issue.
can you restore a back up that you have before 14.04.2019 ?

so we can continue.

The topic ‘[Closed] Home Page Language Switcher’ is closed to new replies.