This thread is resolved. Here is a description of the problem and solution.

Problem: Home page meta title and description not translatable with All In One SEO Pack Solution: 1) Find _aioseop_title and _aioseop_description custom fields 2) Set these to "Translate" Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by sharamV 1 year, 6 months ago.

Assigned support staff: Bruno Kos.

Author Posts
December 7, 2018 at 11:37 am #2977591

sharamV

Hello

I discovered thet when i save english home page it overwrite meta title and meta description in all other home page translation. I don't understand the problem, please assist.

Thank you!
Sharam

December 10, 2018 at 2:21 pm #2984685

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support.

Based on Debug information, I can see that you are using All In One SEO Pack, which is compatible with WPML, so I am assuming that you are using it to translate meta fields?

It is possible that in your case, the home page in another language is actually a duplicate and not a translation of the main home page. If you want to have different content on both pages, you would need to convert a duplicate to a translation. You can do this by:
- go to the editor, in the section Language, click the button Translate independently.

You can find out more about this on the following link:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/#convert-between-translation-and-duplicate

Once you perform steps above, you will be able to translate meta fields and all the other content on translated page.

Regards,
Bruno Kos

December 10, 2018 at 4:11 pm #2985295

sharamV

Hi Bruno,

Thank you for your message. Yes we are using All in One SEO but i am not sure that we use it translate meta field, it has almost default setting.

The home pages are not duplicated i can change the content without overwriting other home page translation, it is only meta field that overwrites so it must be something else.

Regards,
Sharam

December 10, 2018 at 5:03 pm #2985464

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Based on the debug log you provided, both:

 _aioseop_title
_aioseop_description

have the value set to 2, meaning that within WPML these are set to "Translate" and should carry individual values based on what the site admin inputs on translated pages.

Therefore, can you try the following first:
- update WPML to 4.1.2 (if you don't see a message in Dashboard yet, you can download your copy from https://wpml.org/account/downloads/)
- increase WP_MEMORY_LIMIT to at least 256MB so that the site conforms to our minimum requirements:
https://wpml.org/home/minimum-requirements/
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Your current value is 40MB.

Once you do it, try saving field(s) again.

If the issue doesn't get resolved after the above steps, we will try other approaches.

Regards,
Bruno Kos

December 18, 2018 at 7:51 am #3011176

sharamV

My issue is resolved now. Thank you!