This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by jefA 11 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 10, 2018 at 12:57 pm #2804298

jefA

I am trying to: switch language of home page

Link to a page where the issue can be seen: see provided URL

I expected to see: the language of the menu to change

Instead, I got: the current language remains active

October 11, 2018 at 8:56 am #2807237

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Have you translated the Homepage to the secondary language? Maybe you are having the issue because of the older version of WPML. Please upgrade to the latest version after a site backup and check the bug is existing or not.

If you are still having the issue, please try the following steps to track the issue.

a) Visit WPML>>Languages
b) Scroll down to *Footer language switcher* section
c) Add a *Footer language switcher* to the site(just for testing)
d) Then visit the frontend and make sure *Footer language switcher* is working as expected in the homepage or not

--
Thanks!

Bigul

October 16, 2018 at 1:37 pm #2821134

jefA

Hi Bigul,

thank you for your prompt response. I've followed your advise: backed up the site and upgraded the plug-in to the latest version, however, the issue remains.

I've tested with the footer language switcher and can confirm the following:
- the switcher is visible and functions only within the wordpress platform and not when the site is live.
- the language can still not be switched on the homepage
- projects in both languages under the "work" and "werk" page load within the wordpress platform.
- additional projects in English load when site is live.
- additional projects in Dutch do not load when site is live.

Could the custom code for the position of the language switcher within the theme impact this issue?

appreciate your response soonest.

Kind regards,

J

October 17, 2018 at 9:08 am #2823898

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

October 17, 2018 at 5:20 pm #2825475

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. It looks the issue is happening because of the compatibility issues. Therefore please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

October 20, 2018 at 10:53 am #2834103

jefA

Hi Bigul,

Please proceed wth the Duplicator to debug the issue. If I need to do anything on my end, please let me know.

Thank you!

Kind regards,

J

October 22, 2018 at 9:55 am #2837495

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the permission. I have configured the Duplicator package on my local server. But not able to reproduce the issue on my local server. The language switcher is working for me in both languages.

Therefore I have a request. Please add the following code in *wp-config.php* file of your site root(after a backup). Then resave the Permalinks from Settings>>Permlinks and make sure the issue is existing or not.

define('WP_SITEURL', '<em><u>hidden link</u></em>' );

define('WP_HOME', '<em><u>hidden link</u></em>' );

Please replace the hidden link; with your actual site URL.

Please try it and let me know your feedback.

--
Thanks!

Bigul

October 23, 2018 at 12:10 pm #2842252

jefA

Hi Bigul,

I was unsuccessful with the additional code. I updated the *wp-config.php* file however, was not able to access the site anymore. I reactivated a backup made 21-10-2018 to regain access.
With regards to the Permalinks, I was not able to reserve these under settings.

Please advise.

Kind regards,

J

October 23, 2018 at 4:24 pm #2843553

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have made the changes in *wp-config.php* file of your site now and it is showing the expected result for language switcher in Homepage. Please check after clearing the caches and let me know your feedback.

--
Thanks!

Bigul

October 24, 2018 at 4:39 pm #2847310

jefA

Hi Bigul,

Thank you for your assistance. The issue with the homepage is resolved.
As you are familiar with my site, I would like to inquire if you can assist with the second issue: where the additional projects under the second language (dutch) do not load when pressing "load more", or do I need to start a new ticket?

Thank you in advance.

Kind regards,

J

October 25, 2018 at 12:40 pm #2849760

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Bigul is not available for a few weeks, so I am taking care of this ticket further.

As the original issue is resolved may I kindly ask you please to open a new ticket for your additional question?

This will help other users with similar problems to find solutions when searching the forum.

Thanks

October 26, 2018 at 3:20 pm #2853491

jefA

My issue is resolved now. Thank you!