This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Home page not translated: but it is!

Solution:HOME PAGE was in the trash. restoring it resolved the issue

Relevant Documentation:

This topic contains 2 replies, has 2 voices.

Last updated by Rob Coers 1 year, 4 months ago.

Assigned support staff: Bobby.

Author Posts
May 29, 2018 at 7:21 pm #2248065

Rob Coers

I am trying to: translate the HOME page from Dutch into English

Link to a page where the issue can be seen: hidden link

I expected to see: The English HOME and a language switcher

Instead, I got: A missing menu item for the HOME page

Debug info says it's invalid?

Please see my screencast here: hidden link

Thank you!
Rob

May 29, 2018 at 9:18 pm #2248440

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for sharing with us the screencast !

As a test please go to your "Home Page" and click "edit" for the default language, then use the language switcher flag on the top header and switch to the secondary language.

are you able to see it in the backend now viewing with the standard WP editor ?

what are your results if you click on the permalink from within the edit page, does the page open ?

In addition Please go to WPML => Support , and click on "Troubleshooting" while in the Troubleshooting page please perform the actions. (specifically "set language information" but i recommend performing all of them"

let me know your results

May 30, 2018 at 6:13 am #2249002

Rob Coers

When I followed your solution, it appeared that the HOME page was in the trash. I've made earlier tests with this page. I restored it, and now all is working fine.