This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Andreas W. 3 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 15, 2019 at 8:16 pm #3820065

miaS-3

I am trying to:

The articles in English and German are connected and display nicely on the home page (as long as I don't access it by clicking on "Start"(=Home) as indicated above in 1)... however, if I click on an English article and click on the German flag in the header menu (or vice versa), it doesn't take me to the respective language version of the article but back to the home page. How can I change this?

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

May 15, 2019 at 11:30 pm #3820527

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML support.

Could you please go to WPML -> Languages -> Site URL Structure and choose the option "language in directories"?

Your default language would be displayed as hidden link.

The additional languages would go as example as hidden link for German. You can further click the checkbox for "use directory for default language". In this case also the default language will receive a language directory in its slug. (Example hidden link with default language German).

Next, go to Settings -> Permlinks and choose a "pretty" permalink structure like "Name & Date" as example. Avoid to choose "Plain", it will be always better to set this structure to a more complex value.
At last only click the save button and let me know if the issue persists.

Kind regards
Andreas

May 19, 2019 at 8:09 pm #3842489

miaS-3

Hi Andreas,

thanks for your support!

I followed all instructions, but I still have the same issue: I go to the English homepage, click on the first article in English and then select the German flag on the top (Sprachumschalter) - and it takes me right back to the German version of the home page instead of displaying the German version of the article.

Do you have any idea what could solve the problem?

Cheers,
Mia

May 20, 2019 at 3:51 pm #3848481

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Do I understand right that the homepage is completely translated and even after saving the permalinks the site is not showing up?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 26, 2019 at 5:31 pm #3892157

miaS-3

Hi Andreas,

Have you accessed the site yet? Now there is a huge error: only the English website shows and as soon as I or any visitors click on an article or the flags to swith languages they can't access any articles anymore. All that is shown is an error message. Since I haven't touched the website since my last message to you, I don't know what has caused this issue. Also, there are now 3 flags instead of 2 showing, 2 of them German. I also didn't set this up. Please check the website, its a mess at this point and I don't now how this happened since I haven't modified anything myself recently. It seems things have gotten worse, at least when I was working on the site, visitors could still read the articles 🙁 can you please help me out here?

Thanks in advance!

Best
Mia

May 26, 2019 at 11:09 pm #3892509

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry to hear that you are experiencing issues.

Until now I was not able to take a look at you site as I did not receive the credentials yet.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 30, 2019 at 10:44 pm #3926433

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The provided FTP access sadly does not grant access. Is there maybe an additional directoy password?

Kind regards
Andreas

June 1, 2019 at 4:15 am #3934169

miaS-3

Hi Andreas,

Thanks for your help. I'm on a trip until mid June right now and don't have a computer with me. Is it possible to keep this ticket open until then?

Thanks for your support and I hope we can find a solution soon.

Best
Mia

June 3, 2019 at 2:48 pm #3943697

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Mia,

Thank you for letting me know.

Please feel free to contact me again once you return from your trip. This ticket will stay open until you next reply or at least for 14 days.

Kind regards
Andreas

July 2, 2019 at 8:30 pm #4129971

miaS-3

Hello Andreas,

Thanks for your patience! 🙂 I'm back now and found that the site was being displayed in a different theme. I switched it back to my theme of choice and reactivated all WPML plug ins.

Now, once again, the articles are assigned correctly to each language but as soon as I want to read the articles and click on them I get an error message:

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Do you know why this happens? It seems like we're back where the problem first started, so I'm confused. Do you have any more ideas?

Thanks in advance!

Kind regards,

Mia

July 2, 2019 at 10:46 pm #4130321

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Mia,

Could you please connect to the server and check for the error.log file. Please provide me any given errors.

You might paste the file to http://www.pastebin.com and send me the link in case it is very huge.

Also enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Please also provide access to the site and to the server again, as the earlier provided credentials are not valid anymore. I have enabled the private message.

Kind regards
Andreas

The topic ‘[Closed] Home page only shows articles in one language, page empty in other language’ is closed to new replies.