Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Mihai Apetrei 2 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
November 20, 2019 at 10:25 pm #4984545

Richard Canny

I am trying to:
On my home page, the spanish language flag selector (and our logo) is taking users to a strange spanish rul blog post and not the spanish home page
Link to a page where the issue can be seen:
hidden link

I expected to see:

When I click on the spanish flag on the home page, I expect to go to:
hidden link

Instead, I got:

but instead I arrive at:
hidden link

It's the same if I click on the Ultimation logo on a spanish web page.

Did a widget get corrupted?

November 21, 2019 at 12:17 am #4984817

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From my tests, there are no redirects happening when I'm clicking the Spanish flag while being on any other language (or on the logo while being on Spanish).

My guess is that you might be seeing a cached version of your site.

Can you please:

1. Open an incognito window or use another browser
2. Also, please try to use a different internet connection, like sharing a hotspot from your phone to your laptop or visit the site from your phone, using the phone data.

This should not happen anymore.

Please let me know how that goes.

PS: Just a note that I am at the end of my shift at the moment and I will be able to get back to you tomorrow.

Kind regards,
Mihai Apetrei