This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by herveN-2 1 year ago.

Assigned support staff: Yvette.

Author Posts
September 27, 2018 at 9:09 am

herveN-2

I am trying to: get rid of the title page on the home page for translated pages (works ok for the default language)

Link to a page where the issue can be seen: hidden link

I expected to see: I don't want the page title to appear

Instead, I got: the page title for each language

September 27, 2018 at 5:37 pm #2771409

herveN-2

hi !

WPML team please do not make any changes on the online website as we are currently building it.

We have found a manual solution thanks to Elementor, so we are not blocked. Nevertheless, we would be interested in your solution.

Thanks a lot in advance

Kind regards

September 28, 2018 at 8:20 am #2772891

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

This sounds like there coudl be a theme configuration setting for the home page template that will show the page title or not.

Can this be the case?

If so, this theme option would need to be translated to all target langauges.
I will be installing the duplicator package you provided on my local system but if you could advise about the theme setting, that could help me work faster.

Thanks

September 28, 2018 at 8:32 am #2772912

herveN-2

Hello Yvette,

Thanks a lot for your message.

I just went into theme > personalization > home page settings

There I can just select the page (which is called "Accueil - Video" in our case). The page itself has the button "hide title" switched on => ok in French...

I'm affraid of not being too helpfull here but I hope this help.

In anycase, thanks a lot in advance for your work !

Thans again

Enjoy Provence Team

September 28, 2018 at 1:47 pm #2774102

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes it does!

But I am having trouble acessing your site dashboard. The login page does not show up. Do you have a special login page where I can use the credentials you provided?

Also, please install and activate the following plugins:
ARI Adminer
Multilingual Tools
https://wpml.org/documentation/related-projects/wpml-compatibility-test-tools-plugin/

I believe I can fix this directly on your site once I have access to it.
Thanks for advising

September 28, 2018 at 3:29 pm #2774316

herveN-2

hi Yvette,

Sorry for this late reply.

OK I have downloaded and activated ARI Adminer and Multilingual Tools.

About the difficulties you face accessing the admin panel, I have tested it and it works. Correct login and correct password.

I can also access the admin panel from the link I gave you. I don't understand.

Could you please try again ?

Thanks a lot !

Kind regards

Enjoy Provence Team

September 28, 2018 at 3:35 pm #2774328

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

This is what happens when I use the link you provided:

hidden link

There is a 404 redirection.

September 28, 2018 at 3:42 pm #2774357

herveN-2

ok seen, I try to understand.

May be we have forbidden access from another URL during the settings. I try to remember where we could have done that.

September 28, 2018 at 3:57 pm #2774369

herveN-2

OK it's ok now you can access it.

Problem was coming from the downloading and activating of the plugin called WPS hide login (even if the "usual"... URL has not been replace with something else (so just the fact to download and activate the plugin causes that)

Sorry for that !

Thanks a lot

September 30, 2018 at 6:50 pm #2776721

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I set the following custom fields to "copy"

_elementor_page_settings
themo_hide_title

I then updated the original page and all translations. Now the "hide page title" setting is copied ocer to the translations.

I hope this resolves your issue.

October 1, 2018 at 6:32 am #2777192

herveN-2

Hello Yvette,

I just read your message. Thank you for this.

I can't test right now as I face a new issue : I can't reach my admin panel either by the url or by the host account... It says "You're not allowed to reach this page".

I try to solve this, then implement your solution and keep you informed.

Thanks agains

October 1, 2018 at 7:23 am #2777230

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok.

It is resolved on the test site - you need to set the translation options in WPML -> Settings -> Custom Field translation.

You must complete all translations in progress.

Kind regards

October 1, 2018 at 8:18 am #2777333

herveN-2

Thanks a lot Yvette,

I've got my access back. I will keep you informed and up date the status later as I face now another issue and I have opened a ticket with the Theme provider.

The issue is : Hello,

"When go to Page > home page > lay out > hide title ON/OFF, if I set "ON" and update, the switch goes back to "OFF"."

So until this is not solved, I can't test your solution for the one I thank you again very much.

Talk to you soon

October 1, 2018 at 8:42 am #2777465

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

No problems.

October 2, 2018 at 10:19 am #2781094

herveN-2

Hello Yvette,

We have done what you've said and we have also modify the page with elementor as shown in the attached image. Once all done everything worked perfectly.

Thanks a lot for your really appreciated help.

Have a nice day !

Enjoy Provence Team