This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Andreas W. 1 month, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
July 3, 2019 at 9:28 pm #4138973

Lorry Gombos

Hello,

I was checking few things and all the sudden I noticed that homepages of all other translations - FR, DE, IT, ES are showing title that is same as main ENG. All other pages titles are working quite fine on translated pages. I tried to check this: https://wpml.org/forums/topic/home-page-meta-title-and-description-overwrite-other-home-page-translation/ but there are no such custom fields inside. Still, the most odd thing is that this was working until recently and now only on the homepage it stops working.

Can you please help me? Note: Do not touch please main (production site) - if necessary just replicate things on your server.

July 3, 2019 at 11:42 pm #4139317

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Are those headings part of a WPBakery Page Builder element? Did I understand right that these titles were translated earlier and suddenly changed?

Did you try to translate those pages again?

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the results. In case the debug-log is very long please add it to a web tool like pastebin.com and send me the link.

Kind regards,
Andreas

July 4, 2019 at 9:01 am #4141497

Lorry Gombos

Hi Andreas, those headings are not part of WPBakery Page Builder. I'm talking about All in One SEO Pack which is generating page title. Check my first two images: all-in-one-seo-pack.png and english.png. It is showing what is added inside of the plugin that should be compatible with WPML in english (default language). But when you try any other language and you add normally new page title, then check next two images: all-in-one-seo-pack-french.png and french.png you'll see that no matter different title is set up, output is the same just like in english language.

I hope that it is more clearer now.

July 4, 2019 at 9:02 am #4141603

Lorry Gombos

Hi Andreas, those headings are not part of WPBakery Page Builder.

Check my first two images: all-in-one-seo-pack.png and english.png. It is showing what is added inside of the plugin that should be compatible with WPML in english (default language). But when you try any other language and you add normally new page title, then check next two images: all-in-one-seo-pack-french.png and french.png you'll see that no matter different title is set up, output is the same just like in english language.

I hope that it is more clearer now.

July 4, 2019 at 2:31 pm #4144481

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

July 5, 2019 at 5:01 am #4147479

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing you to let you know that I was debugging the site on localhost and the issue about the All In One SEP Pack preview widget on the translated page actually got solved after deactivating several plugins.

Somehow , after reactivating a set off plugins the site broke and until now I was not able to connect myself.

The issue seems to be related to a fialur einside of the database. The debug.log shows similar errors like this one:

WordPress database error Table 'outback.outb_wp_wysija_queue' doesn't exist for query SELECT COUNT(email_id) as count FROM `outb_wp_wysija_queue` WHERE send_at < 1562129152 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, init_wysija_cron, WYSIJA_help_cron->run, WYSIJA_help_cron->check_scheduled_task, WYSIJA_help_cron->run_scheduled_task, WYSIJA::croned_queue, WYSIJA_help_queue->process, WYSIJA_help_queue->clear, WYSIJA_model->count, WYSIJA_model->query

Did you enable the wp-debug feature on zour live site and experience similar errors?

https://wpml.org/documentation/support/debugging-wpml/

I earlier today tried to recreate the issue on a new installation but the plugin behaves as expected here with WPML and its add-on. I would like to invite you to check out the site and maybe add the Outback Motortek Theme and the plugins used to create the content, for further testing.

One Click Login: hidden link

I will be investigating about the issue further tomorrow and contact you then.

I hope for your understanding.

Kind regards
Andreas

July 5, 2019 at 8:51 am #4149283

Lorry Gombos

Hello Andreas,

What several plugins statement you mean? I tried to disable all plugins but this was not fixed! Can you please be more specific?

I hope that site was not down for too long... Because we have orders in there... I see database error but I want to tell you that we are not using wysija newletter plugin anymore (Mailpoet 2) on that site. I've enabled wp-debug on that site yes. Still, when you access hidden link title is the same as in english ( Outback Motortek USA in Monroe, Virginia ) even it should be Outback Motortek USA en Monroe, Virginia. A bit difference, but on the other shop this difference is much bigger one... And issue is most surely the same.

I cannot see live site on hidden link so its kind a helpless here (as I need to see the title).

Hope that you will reach some solution.

Keep me posted.

Thank you.

July 5, 2019 at 2:59 pm #4152273

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

When I was talking about that the site "crashed" I refered to the copy which I took and that was running on my local system. I did not take any changes to your live site.

Indeed, we do not have the possibility to verify how a site copy is displayed on Goolge. Even pages that are migrated to our test server are usually not indexed on Google.

Anyhow, while debugging I realized one issue in regards to the snippet preview of the All In One SEO Pack, which was solved after deactivating various plugins.

In fact the preview snippet works while editing the title or description but once the site is saved it switches back to default language. It might be that the issue you see on Google is linked to that same problem.

This issue actually is not linked to WPML, as it also occurs if WPML and its add-ons Translation Management, String Translation and WooCommerce MUltilingual are deactivated.

Could you please verify this by disabling the WPML plugins on your live site and then trying to update the SEO title, desciption or keywords?

I would advise you to contact the All In One SEO Pack support for further assistance.

About the Wysija Newletter Plugin database error you maybe might contact their support. It might be that you could delete these database tables.

Kind regards
Andreas

July 5, 2019 at 8:46 pm #4153931

Lorry Gombos

Hi Andreas,

You are making me to look silly and repeating myself. I would like if some senior member can get on this because obviously you are circling around with same answers.

As I stated, before contacting you, I tried to deactivate all plugins except theme core ones (2 of them), All in One SEO and WPML. You stated that if I deactivate WPML then it will be working? What will be working when there will be no translation pages then.

Really bad support till now I must say. Like you don't understand what I'm writing... I'll describe once more core of this issue:

1. hidden link - on the homepage there are title. That title can be seen inside of the source <title>Outback Motortek USA in Monroe, Virginia</title>

2. hidden link - spanish translation (and every other translation on another shop which is behaving on a same way) title is <title>Outback Motortek USA in Monroe, Virginia</title> and inside of the All in One SEO it is set up to be different than that.

If you disable WPML, then on translation pages will be active.

Pages do not need to be indexed on google, they just need to be seen in the frontend version not just in the WP dashboard. That way you cannot see real title (or you maybe can...).

Wysija Newsletter Plugin has nothing to do with that.

I really do hope that someone more experienced from WPML can jump in and help with this.

Thanks

July 5, 2019 at 10:13 pm #4154061

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Sorry for the misunderstanding.

I do understand the frustation but I think you were not following my explications:

Please proceed as followed:

1) Disable WPML and all WPML add-ons
2) Go to a page and edit the SEO title.
3) Check that the snippet preview got updated
4) Now update or save the page
5) Realize that the SEO snippet perview switches back to the default title, description, keywords?

Here a video that should clarify the issue a little further.
hidden link

As I said, I tested the plugin on a new installation and there is not any issue with translating it using WPML at its latest version. Once hI change any field realted to the SEO on my test the preview snippets stays updated and never switches back to default.

This is why I think the issue is related to something else and zou might consider contacting the All In One SEO Support.

Kind regards
Andreas

July 5, 2019 at 10:44 pm #4154093

Lorry Gombos

Thank you Andreas. I see your point now. Yes, that is true. But how to resolve this? I mean All in One SEO should be compatible with WPML... but seems like there are issue with this. Can you at least suggest something? Thanks

July 6, 2019 at 8:11 pm #4156325

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It seems to be that the plugin All In One SEO Pack on your current setup is having a compatiblity issue with a different plugin or the theme.

As you see on mz test there is a weird bahvior while WPML id disabled. What I am trzing to explain is that there is not any compatilbity issue with WPML, as I tested the plugin on a new install without issues.

Please procced as followed by taking my video as example:

1) Let WPML and all add-ons for WPML deactivated

2) Open the page editor for the homepage and open the plugins in another window.

3) Now disable all plugins and test only with All In One SEO Pack

4a) Test again the example from my video. If the plugin still shows unexpected behavior the issue is not linked to any other plugin. In this case change to a default theme like Twenty Seventeen. If this solves the issue contact the theme support of your currently used theme.

4b) In case the plugin behaves normal when all other plugins are deactivated you will need to reactivate the plugins one bz one or in small groups and at the same time test the plugin behavior like in my video. At the moment you realize the issue occurs again it must be linked to the last plugin that has been activated. In this case contact their plugin support.

In general also I would advise you to contact the All In One SEO Pack Support for further assistance. It might be that they already had similar issues with this plugin and will be able to assist you faster.

Kind regards
Andreas