This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 month, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 19, 2020 at 9:26 pm #6172201

zvonimirM-3

I have 2 languages: English and Croatian.

English is my main language.

When I choose to switch from English to Croatian my homepage is still in English.

I've checked all the tickets and my page is translated at 100% and it's published, however when I preview it it's still in English.

THanks

May 20, 2020 at 7:50 pm #6180703

zvonimirM-3

Hi, I would really appreciate some assistance. Thanks

May 20, 2020 at 8:14 pm #6181047

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed look, please, try the steps below:

1 - From your WordPress Dashboard > WPML > Support click the 'Troubleshooting' link and from the 'Clean up' section, peform these actions:

  • Clear the Cache in WPML
  • Set language information

2 - Click to edit the wp-config.php file found in the root directory of your WordPress installation and add the lines of code below:

define('WP_MEMORY_LIMIT', '256M');
define('WP_MAX_MEMORY_LIMIT', '256M');

3 - Now, click to edit your homepage and make a minor editing for it in order to refresh your translation, save it and then click to edit your translation again, resave it and you should be done.

Please, let me know if it fix your issue, have a nice day.

May 20, 2020 at 8:57 pm #6181175

zvonimirM-3

Hi Marcos,

here is what I did:

1. Instructions from this point were done
2. Although I am not developer I managed to add those 2 lines of code (screenshot below)

After doing so I went to edit translation and I am not able to save it, after clicking save and close it remains in saving status (Another screenshot attached)

My homepage which is not showing in Croatian is following: hidden link

Attached is also image showing that I opened my home page in Croatian which is showing in English. On the second screenshot (image called stuck in saving) you can see that once I click Edit Translation it clearly shows I've finished translation (100%) and it's published.

To make it short, I did not fix the issue. 🙁

May 21, 2020 at 11:57 pm #6190925

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 27, 2020 at 12:53 am #6223989

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Unfortunately the provided access details don't seem to be correct, can you review it please? The next reply is marked as private in case you need to resend it safely. Thank you for your collaboration and continued patience, have a nice say.

May 27, 2020 at 8:23 pm #6232811

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Unfortunately it doesn't allow me to see your WordPress settings such as plugins, edit pages and so on.

Please, make sure the provided user access has the proper administrator permissions, otherwise I won't be to investigate your issue into details, thank you for your collaboration and understanding, have a nice day.

May 27, 2020 at 8:36 pm #6232939

zvonimirM-3

Hi,

I've assigned you administrator role. Sorry for missing this detail. Please check now. Thank you

May 29, 2020 at 12:06 am #6244291

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my previous private reply and let me know when the migration process is done. Thanks.

May 29, 2020 at 9:42 am #6248137

zvonimirM-3

Hi Marcos,

I did as you instructed however during migration I got an error. Attached is screenshot.

May 29, 2020 at 8:07 pm #6252705

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case we can try an alternative method of debugging your website safely, for that, please consider:

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

June 3, 2020 at 5:44 pm #6286361

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I've made some tests at my locahost and noticed your issue is related to an issue already fixed in the most recent versions of WPML, so in your case, please try the following:

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

1 - Update your WPML related plugins to their latest versions from your WordPress Dashboard > Plugins settings;

2 - Now, click to edit your homepage translation, finish it checking all the fields as completed and click to save it;

3 - Repeat the same steps for any translation you still see issues;

See: https://wpml.org/errata/elementor-fatal-error-unable-to-translate-content/

Please, let me know if it helps, have a nice day.