This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The Yoast SEO bradcrumbs showing incorrect homepage text.

Solution:

1 - Enter the breadcrumb homepage label in the default language at WordPress Dashboard > SEO > Breadcrumbs

2 - Translate the homepage breadcrumb homepage label using the String Translations at WordPress Dashboard > WPML > String Translation using key '[wpseo_titles]breadcrumbs-home' under the 'admin_texts_wpseo_titles' text domain.

Relevant Documentation:

https://wpml.org/documentation/getting-started-guide/string-translation/

This topic contains 3 replies, has 2 voices.

Last updated by andrewA-19 3 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
June 27, 2019 at 4:13 pm #4101521

andrewA-19

I am trying to: Translate the word "home" in breadcrumbs

Link to a page where the issue can be seen:
hidden link

I expected to see:
Home > sitemap

Instead, I got:
ホーム > sitemap

I have attached a picture of all the translations (which are correct in every place).

June 27, 2019 at 7:01 pm #4102397

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a look in the provided website url and I see the words 'Accueil > Sitemap' for the breadcrumbs navigation, in other words there's a french string for the 'home' word, which indicates we have some issues for these strings in the WPML String Translation. I would need to take a closer look in your WordPress Dashboard in order to understand where these strings are coming from and why they don't appear in english. For that, please consider: I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

June 28, 2019 at 6:51 pm #4109921

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and could confirm the issue. Here are the details regarding this issue and how to fix it:

1 - You website has a custom language called 'United States' and even so you entered a label for your homepage in a different language in your WordPress Dashboard > SEO > Breadcrumbs, doing so you make a confusion in the String Translation for this specific homepage label translation.

2 - In order to fix it I entered the correct english 'Home' text for the homepage label in your Yoast SEO breadcrumbs settings described above, as it only makes sense to enter a label text in the default language.

3 - Now in your WordPress Dashboard > WPML > String Translation I changed the default language of the key '[wpseo_titles]breadcrumbs-home' under the 'admin_texts_wpseo_titles' text domain to your 'United Stated' custom language as it is the default language of your website.

4 - With the steps above you should now be able to properly translate your breadcrumbs 'Home' label to the different languages of your website.

Please, let me know if the above helps to solve your issue or if you need any additional clarifications and details. Have a nice day.

July 1, 2019 at 10:13 am #4117725

andrewA-19

My issue is resolved now. Thank you!