Due to the large volume of support requests, you may experience longer wait until a supporter handles your request. We apologize for the inconvenience this causes. We do not have any recurring unknown issues so we encourage you to please search the forum for other support topics that might be helpful and to review our documentation and look at our erratas page for known issues. A supporter will respond to you as soon as possible.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.

Tagged: , ,

This topic contains 9 replies, has 2 voices, and was last updated by  Anne-Sophie 5 years, 1 month ago. The support staff assigned to this topic is Harshad.

Author Posts
Author Posts
October 12, 2012 at 7:16 pm #79554

Anne-Sophie

Hello,

The theme used on hidden link is Workz, a free one from WPexplorer.com; I installed WPML plugin on it with spanish as first language and english as secondary.

It works fine on pages and posts, but not for the Homepage: all its contents shows both in spanish and english; and I couldn't find any translation option for Homepage Tagline (it's located on Appearance/Theme Setting)

On the Noticias/News part, the link hidden link looks OK, but when entering a single one, the address shows hidden link with "noticias" instead of "news" in the url.

I guess all this issues can be solved by some function, I've been searching for a while but I'm afraid my skills are more than basic. Any help would be most welcome!!

Best regards,
Anne-Sophie

October 13, 2012 at 7:49 am #79585

Harshad

Dear Anne-Sophie,

Please go to wpml -> languages, scroll down to blogs to display section, check if "Only translated posts" option is enabled.

October 13, 2012 at 7:56 am #79587

Anne-Sophie

Hello Harshad, this option is checked, and also the auto-adjust ID (I had a look at your support page http://wpml.org/documentation/support/creating-multilingual-wordpress-themes/language-dependent-ids/)

October 13, 2012 at 8:19 am #79590

Harshad

Dear Anne-Sophie,

Can you please send me your ftp and wp-admin details to my email address?

Please include this forum link for reference.

October 13, 2012 at 8:37 am #79594

Harshad

Dear Anne-Sophie,

Thanks for providing the details.

Can you please check your sites home page now? It should now load single entries per language.

We need to pass, 'suppress_filters' => false as an argument to get_posts().

Can you please confirm the same?

October 13, 2012 at 8:41 am #79596

Anne-Sophie

Wow! It works!! 🙂 Thank you!
The only thing left is the Homepage Tagline located in Appearance/Theme Settings: it doesn't have the option for translation (so appears only one language)...

October 13, 2012 at 8:55 am #79601

Harshad

Dear Anne-Sophie,

The tagline should be available in string translation within context theme workz.

Or use the link below
hidden link

October 13, 2012 at 9:06 am #79602

Anne-Sophie

Thank you Harshad, you're right!

One last thing, on the Noticias/News part, the link hidden link looks OK, but when entering a single one, the address shows hidden link with "noticias" instead of "news" in the url.
By default, it shows "portfolio", but in the function.php file there is an rewrite option, so I put "noticias" which is fine to appear in URL for the spanish part, but of course it doesn't change for english or catalan... (I saw how to do it on this link hidden link)

October 13, 2012 at 9:26 am #79605

Harshad

Dear Anne-Sophie,
Sorry this is not possible at moment.

This task has been scheduled for WPML 2.6.1. It will work in conjunction with our Types plugin.
http://wp-types.com/

October 13, 2012 at 9:44 am #79609

Anne-Sophie

OK, so I put an 'n' instead and it works for all languages. Thank you very much for your very useful help!!
All the best,

Anne-Sophie

The topic ‘[Closed] Homepage: all languages showing at the same time’ is closed to new replies.