This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bruno Kos 4 months ago.

Assigned support staff: Bruno Kos.

Author Posts
June 13, 2019 at 7:08 am #4009761

Marjolein

After installing WPML on my wordpress website, my homepage became 'dutch' and isn't visible in 'pages' as 'homepage'. Now I can't see the rest of my pages, (see image), when I click on 'all' nothing happens.

I also think my default language is set as Dutch, but thats not correct,it should be English.

Can you help me change my default language to English and make my homepage 'English' and get the rest of my pages back?

Thank you.

June 13, 2019 at 8:40 am #4010739

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

June 13, 2019 at 10:33 am #4011977

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

(please ignore my previous message)

June 13, 2019 at 12:33 pm #4012803

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me if you already made some translations, or if you only had pages in English language that yet needed to be translated? I am unable to change the language into English and I suspect there might be some issues with WPML database.

Therefore, if you have not made any translations yet, I would like to consider WPML reset option. The 'Reset' action will deactivate the WPML plugin after it deletes the WPML tables (tables with the 'icl_' prefix) from the database. The action will NOT delete any content (posts, taxonomy terms etc.). It only affects translation and language information that WPML associates with each content type.

Please note that all translations you have sent to remote translation services will be lost if you reset WPML's data. They cannot be recovered later.

If you are using the Advanced Translation Editor, you will lose the translations that are in progress, as well as the existing translation memory and glossary. You will also lose access to purchases, invoices, and history related to your work with the Advanced Translation Editor.

Regards,
Bruno Kos

June 13, 2019 at 2:44 pm #4014051

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It is done - English is now your default language and all the pages are assigned to English as well. You can now translate into Dutch or any other language.

On a side note, I suggest that you make sure that the server conforms to our minimum requirements?
https://wpml.org/home/minimum-requirements/

Based on provided debug information, I can see the following - WP Memory Limit: 40M.

Specifically, I suggest that you set WP Memory limit to at least 256MB:

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

If unsure on how to set this, you can consult your host/server admin to do this. After you increase this value, you can confirm it by checking on WPML -> Support by finding the “Memory limit” value.

Let me know if there's anything else I can help with!

Regards,
Bruno Kos