Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 1 year, 5 months ago.

Assigned support staff: Andreas W..

Author Posts
February 7, 2019 at 3:47 am #3168532


Hi, here is the site I'm working on right now:
hidden link

Access information to view the site:
u - letters
pw - guestpreview

Three issues I'm encountering right now:
1. Link redirects when translated content doesn't exist.
2. Double content on translated pages.
3. General suggestions for how to handle partially translated site for now.

I have very few pages translate right now, though we expect more to come online soon.
Right now, though, I noticed an issue when I view a page that I've marked as "translated", for example:
hidden link

If you click on the top right branch on the nav bar, instead of redirecting to the normal homepage, it redirects to the Arabic homepage, which doesn't exist yet and show blank content:
hidden link

How do I switch this?
If I change the WPML settings to posts & pages = "Translatable - use translation if available or fallback to default language", the link goes to a homepage that looks extremely messed up. I've kept it on that setting so you can see what I'm talking about.

What I would prefer: have it link directly to the default (English) version of the page if a user clicks on that link, rather than redirecting to the Arabic version.


An additional issue that has come up is that on this page, for instance, I am seeing my content double, when viewing the hebrew post:
hidden link

Any idea why that is happening?


In general: how should I handle this site that is probably going to be only partially translated for some time?

Thank you!


February 7, 2019 at 3:00 pm #3170947

Andreas W.

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi David,

Thank you for contacting WPML Support.

Please take note that pages that are translated for the first time with WPML and have not been translated to 100% will not show up on frontend. This must be the reason for the 404 errors.

I would kindly advise you to use the WPML Translation Editor to not only make sure that a page is translated to 100% but also to maintain compatibility when using page builders.
The setting is located on the WPML -> Settings page, under the How to translate posts and pages section.

You explained that you have set posts and pages to "Translatable - use translation if available or fallback to default language". In this case a click on untranslated content on your Arabic site should forward the customer to the English content instead, as long it exists.

You might further create your Arabic homepage as a duplicate of your English homepage. This way you will make sure that there will be a homepage available in the meantime.

Please read the following documentation:

In case you do not have translations available for some pages and posts you might also have the option to hide the language in the meantime. You will find this option at WPML -> Languages -> Hide language. This way the content for this language will not be visible on frontend.

Regarding the duplicated content on your translated pages I am deducing that we handle here with a theme issue. Please make sure to update your current theme to its latest version to see if the issue persist.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:

Kind regards

The topic ‘[Closed] Homepage link redirecting to Arabic homepage despite no translation existing’ is closed to new replies.