This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by garyA-7 1 month, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
August 29, 2019 at 4:23 pm

garyA-7

I've been working with Mihai on an issue with my homepage, which has kind of been resolved. However, as you can see in the screenshot, I have my switchers set but they don't do anything. I go to the homepage and go to the switchers at the bottom of the page and they are not clickable. How do I get these to work and translate my homepage? Thank you.

August 29, 2019 at 4:45 pm #4482815

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

I went to the homepage and the about us page and the language switcher links forwarded me as expected to the respective Portuguese pages.

Could you please verify and give me some more detailed information (links of the pages).

Kind regards
Andreas

August 29, 2019 at 4:53 pm #4482829

garyA-7

Hi Andreas, that's odd, so the homepage switcher links at the bottom of the homepage work for you - see attached image? They don't do anything for me.

August 29, 2019 at 5:26 pm #4482921

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message and my appologies for the misunderstanding.

I can see now that the footer language switcher is working for all pages but it does not show up on the Front-Page.

I was able to recreate the issue using the Pixova Lite Theme on a new WordPress Installation. As soon a page is set as Front-Page the language switcher disappears.

The issue has been escalated to our compatiblity team for further investigation. I will contact you as soon I received feedback.

In the meantime, you could apply a custom language switcher. More information here:

https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

Let me know if you need any assitance.

Kind regards
Andreas

August 29, 2019 at 5:38 pm #4482925

garyA-7

Okay, thanks Andreas, I'll await your response. Thanks also for the link to the custom switcher, but it looks like it involves lots of CSS, which is waaaay beyond my level of expertise 😉

August 29, 2019 at 5:54 pm #4482937

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was able to add the default menu language switcher.

I have changed its layout a little, by applying only flags. I hope this solves the issue in the meantime.

You can design this swtcher at WPML -> Languages -> Menu Language Switcher.

Kind regards,
Andreas

September 3, 2019 at 9:22 pm #4507317

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience.

The WPML footer language switcher was actually there, it only was moved behind the footer.

The issue was fixed by applying some custom CSS inside of the Customizer.
(See screenshot)

Kind regards
Andreas

September 4, 2019 at 6:49 am #4508497

garyA-7

Thank you, Andreas.

September 4, 2019 at 6:52 am #4508575

garyA-7

My issue is resolved now. Thank you!