We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by leoS-4 3 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 25, 2019 at 9:14 pm #4286109

leoS-4

I am trying to: translate the homepage

Link to a page where the issue can be seen:hidden link

I expected to see: a identical homepage

Instead, I got: something completely different. Slider is missing. Also in the Dutch version.

July 25, 2019 at 11:25 pm #4286233

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It most likely happens due an incosistency in the settings of your default language pages and your secondary languages pages. I would need to take a detailed look in your WordPress Dashboard in order to confirm it, for that, please consider: I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 26, 2019 at 8:19 pm #4291733

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your WordPress Dashboard and noticed there's an incosistency in your homepage across your website languages. Please, try the following:

1 - Click to edit your homepage in your default language (english in your case).

2 - Change to your secondary languages using the top admin bar language switcher.

3 - Compare your page 'Appearance Options' and 'Page Attributes' settings and make sure your settings are the same for all the website languages and update your pages accordingly.

Please, let me know if you need any additional instructions and clarifications. Have a nice day.

July 27, 2019 at 3:20 am #4292653

leoS-4

I did what you suggested, but there was nothing different and all is the same. How can I start over without loosing the work I did so far?

July 27, 2019 at 4:15 am #4292769

leoS-4

I deleted German and Dutch languages and then added them again to start over. When I create a copy of the English homepage for the translations, the header is a map, not the slider of the English page.

Also, when I change the order of the languages in the Language switcher options, nothing happens.

July 29, 2019 at 2:07 pm #4300643

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting due the weekend. I took a detailed look in your page settings of your different homepage and noticed the settings were not set to be the same for all the languages. I adjusted it and you can see the results at: hidden link. Specifically here is what you need to do:

1 - Click to edit your homepage WordPress > Pages settings and look for the 'Page Settings', 'Appearance Options, 'Sidebar Settings and 'Page Attributes'. See attached screenshot (customer_screen_default_lang_01 and customer_screen_default_lang_01 ).

2 - Change to your secondary languages and make sure these settings are exactly the same. See attached screenshot (customer_screen_secondary_lang_01) and update your page accordingly.

Please, let me know if you need any additional assistance and clarifications, have a nice day.

July 29, 2019 at 7:22 pm #4303251

leoS-4

Sorry Marcos, but I'm really getting annoyed. You tell me the same thing three times. I keep telling you it is not working!

I have a different homepage for every language. Why don't you just follow your own instructions and get things right?

July 31, 2019 at 2:47 am #4311331

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for any inconvenience I may have caused for you. You are right the settings for the homepage translations are being reseted automatically, I suspect of a cache issue, a detailed investigation is needed here. For that, please, consider: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

July 31, 2019 at 7:03 pm #4317313

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website settings and here are the results of my tests and investigations:

1 - You didn't have your homepage page set as the home of your website in your WordPress Dashboard > Settings > Reading >
Your homepage displays
and it was the cause of the inconsistency between your default and translated homepages. I fixed it and now your homepage are showed consistently.

2 - Your theme lists your most recent properties added in your WordPress Dashboard > Listings as the content of your theme slider. For now you will see the slider will list the same unstralated properties listing, it happens because I set the 'Listings (estate_property' post type as 'Translatable - use translation if available or fallback to default language' the purpose here is only to demonstrate your homepages are working properly, before you begin the actual translation process (see: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/). You confirm the results at:

English homepage: hidden link
German homepage: hidden link
Dutch homepage: hidden link

You can now begin your translation work:

1 - Homepage listings

1.1 - You can add translation for all your properties listings in your WordPress Dashboard > Listings. You will notice the properties has a lot of custom fields, this is why you should check our instructions at: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/ in order to learn more on how to properly setup these custom fields for translations.

2 - Homepage travel tips

2.1 - These are regular posts and this way you can translate them in your WordPress Dashboard > Posts settings.

3 - Footer widgets

3.1 - Please, follow our dedicated docs to learn more on how to properly translate your website widgets at: https://wpml.org/documentation/getting-started-guide/translating-widgets/

Please, let me know if it works and if you need any further assistance and clarifications. Have a nice day.

August 1, 2019 at 4:20 am #4318673

leoS-4

Thank you very much Marcos! I learned a lot.

Kind regards,
Leo

August 1, 2019 at 4:21 am #4318683

leoS-4

My issue is resolved now. Thank you!